Visual Studio crashes for C++ After installing 11.1.060

Visual Studio crashes for C++ After installing 11.1.060

After installing 11.1.060, when I set a breakpoint in other VS2008 projects that only have only C++ code, when debugging and the breakpoint gets hit Visual Studio crashes. Uninstall 11.1.060 and the crashes do not occur. It seems I can debug my FORTRAN projects without problems, but not C++ projects. Is this a known issue? It is very repeatable for me. I'm running on a 64 bit machine, running 64 bit apps. Vista Ultimate 64 is the OS. VS2008 SP1 installed.

Thanks,

Dave

51 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Steve Lionel (Intel)'s picture

This is not an issue I have seen reported before. I'll run some tests and see if I can reproduce it.

Steve
Steve Lionel (Intel)'s picture

I have not been able to reproduce this. I suggest you uninstall Intel Visual Fortran, do a "repair" on Visual Studio, then reinstall Fortran. Let me know what happens.

Steve

I tried that with no success. Then uninstalling 11.1.060 makes it so that my C++ project doesn't crash VS when debugging. I also tried creating a simple C++ project. That project was fine while debugging. So I suspect simple applications do not hit the failure. I'm debugging an .arx that is loaded into AutoCAD. Not a trivial application by any means. Multi-threaded. multiple levels of dll's. I can't use 11.1.060 when it causes this type of problem for me. I don't know how to debug this type of issue so any help is appreciated.

Dave

Steve Lionel (Intel)'s picture

Try this to start. Go to C:\Program Files\Microsoft Visual Studio 9.0\Common7\Packages\Debugger and rename ForDbgEE.dll to ForDbgEEx.dll. Restart VS and see if the problem persists. This is a diagnosis step - it will disable Fortran debugging.

Steve

Your instructions look like they are for a 32 bit machine. I'm running a 64 bit application on a 64 bit machine and OS. I went to Program Files (x86) and renamed the application in that path.Debugging myC++ appstill has the same problem, so it doesn't appear to be using that dll.

Dave

Steve,

Any more help for this? How do you summit a problem like this is seems totally related to the installer and what was installed previously. I have to keep uninstalling 11.1.060 to do any work with C++. And I know my 11.1.051 version still works fine, but obviously has bugs in the compiler.

Dave

Steve Lionel (Intel)'s picture

I have not seen other reports of this problem. I'll ask you to completely uninstall Fortran and Visual Studio 2008 and then delete the Microsoft Visual Studio 9.0 folder. Then reinstall VS and VS2008 SP1. Now install 11.1.060 and see if you still have problems.

Steve

It still crashes after doing all the uninstalls, deleting the directories, and doing a reinstall. Seems to be a very repeatable problem.

Dave

Les Neilson's picture

Dave,
There must be something about your setup :-(
I have the same : VS2008 SP1, Vista Ultimate 64bit and IVF 11.1.060
I have pure C++ projects, mixed C++/C/Fortran projects and pure Fortran projects and can set breakpoints in any of them without VS crashing (so far!).

I know it doesn't help other than saying "well it should work"

Les

Steve,

I'm trying to uninstall all of the old versions of IVF.But I have one left and it won't uninstall. 11.0.066. When I hit uninstall from the Programs and Features page, it says "another instance of uninstall was launched. Please wait while it is finished." I wait 5 hours. Then I rebooted. The message is still there. Doesn't seem to be an uninstall running. How do I get by that?

Thanks,

Dave

Steve Lionel (Intel)'s picture

Install the Windows Installer Cleanup Utility and use it to remove 11.0.

Steve

I tried using the Windows Installer Clean Up utility. There were 4 items listed for 11.0.066. It got rid of all of them from the list. But going to Programs and Features, it still lists IVF Compiler Pro 11.0.066. And trying to uninstall that still generates the message that "Another instance of uninstall was launched. Please wait while it is finished...". But there isn't anything MSI* running under the task manager. And I have rebooted to try and clear that. I tried running the installer again (for 11.0.066) and it ran fine. But still won't uninstall giving the same message. Help!

Dave

Steve Lionel (Intel)'s picture

I don't think I have ever run into this situation before, where the Windows Installer Cleanup Utility didn't solve the problem. If you still see it in Programs and Features, you may have missed an entry.

You can try going into the registry editor and deleting the key HHEY_LOCAL_MACHINE\Software\Intel\Compilers\Fortran, rebooting, and trying the install again.

Steve

It is pretty hard to "miss" entries when they are in alphabetical order(i've seen the Documentation item that is there for the compiler which makes me wonder why it isn't IVF documentation instead of Documentaton for VFC). BUt I have performed the deleting of the key and rebooting. Trying to to uninstall with the same message. Reinstalling, and it still won't uninstall with the same message. Cleaning out all of the 11.0.066 items with Windows Installer Clean UP, which still leaves the compiler listed in Programs and Features. I then tried installing 11.1.054. That version too causes VS to crash for my main projects. Uninstalling 11.1.054 fixes the crashing problem. It is this uninstall fixing it that I think really points to the something the IVF installer is doing to cause this problem. If it were something else why does removing it fix the issue?

Dave

Steve Lionel (Intel)'s picture

Uninstalling removes the Fortran debugging support which inserts itself into the normal VS debugging code using a "switcher" DLL. It could be that this switcher is causing your problem, but I have not seen anyone else report this so there must be something else going on.

Try this - boot into "Safe Mode" and try the debugging steps again - does it still crash? If not, this tells me that some background process on your system is interfering with the debugger somehow.

Steve

Since my application runs in AutoCAD, to debug it I need to run AutoCAD. But AutoCAD won't run in safe mode because services they require for licensing are not available. They suggest doing this:

http://usa.autodesk.com/adsk/servlet/ps/item?siteID=123112&id=6453117&li...

But I'm not sure that will do what you want. Does it? If so I will try.

I'd really like to get rid of 11.0.066. Any more suggestions on how to do that?

Dave

Steve Lionel (Intel)'s picture

Yes, that sounds like a good suggestion to run in Safe Mode.

I have never seen a situation where a program shows as installed in Add/Remove Programs (or the programs list in Vista/Win7) and it doesn't show using the cleanup utility. What happens now if you try to uninstall using the normal uninstall?

Steve

what do you mean by normal uninstall? Via the Programs and Features page, I still get the same message that it is being uninstalled and to wait. It isn't in the Windows Installer Clean Up list so It can't be uninstalled from there.

Dave

Steve Lionel (Intel)'s picture

I have sent a message to our install experts asking for help with this. When I hear back I will let you know.

Steve

I haven't been able to get AutoCAD to run in Safe Mode as it needs Workstation service and that won't start up even when selected. I'm goin to AutoDesk for help on that. In the meantime I keep uninstalling IVF when I need to run VS for VC++ and installing IVF when I need fortran. But I need both multiple times per day so this is really really slowing me down.

Dave

Steve Lionel (Intel)'s picture

I have been given the following suggestion:

  1. Open a command prompt as Administrator (right click on the shortcut for Command Prompt, under Accessories, and select Start as Administrator.)
  2. Change directory (cd) to Program Files\Intel\Compiler\11.0\066\fortran\uninstall
  3. Type the command: uninstall.exe c uninstall_cprof.ini -u

Let me know how that works.

Steve
Steve Lionel (Intel)'s picture

Try just renaming C:\Program Files\Microsoft Visual Studio 9.0\Common7\Packages\Debugger\ForDbgSW.dll to something else and see if that works instead of an uninstall.

Steve

I tried the uninstall command. It seemed to run okay, but I found that 11.0.066 was still listed as an application in Programs and Features, and it still had a listing under Start->All Programs->Intel...
And that I could still open the build environment cmd window. So I tried running it again. The second time I got the program has encountered an error window, and then the same message that the application was being uninstalled please wait message that I get running the uninstall from the Programs and Features menu.

And it is still there...

Dave

Maybe I should note again that I have a 64 bit machine so I keep changing your path names to be Program Files (x86) instead of just Program Files.

Steve Lionel (Intel)'s picture

Yes, that would be correct.

Steve

Steve,

Did you see that I tried your suggestion and it failed? It was in the post above the one you responded too.

Dave

Steve Lionel (Intel)'s picture

Ok, the uninstall failed. I will ask the developers again about this. Did you try renaming the DLL?

Steve

After installing 11.1.060 I renamed ForDbgSW.dll and tried to debug my AutoCAD plugin. It still fails when it hits a breakpoint in the code. What can you suggest we try to fix that now?

Dave

Steve Lionel (Intel)'s picture

Please create a simple "hello world" C++ application and try to debug that - do you see the same error?

Steve

No it doesn't have the same error. Simple applications seem tohit breakpoints fine. But then it isn't capable of multiple threads either.It also isn't the same since I start up AutoCAD, which loads my .arx. Fortran programs don't give the same error either. But as soon as I uninstall 11.1.060 I can debug my .arx applications.

Dave

Steve Lionel (Intel)'s picture

I have to wonder, then, if your .arx application is corrupting memory somehow. But why renaming the switcher DLL doesn't eliminate the problem is very odd, as that suggests that it isn't the Fortran debug support that is the issue.

I suppose the next test is to do a "modify" on Fortran and remove the VS integration, then try your test again.

Steve

I installed 11.1.060 but unselected the integration into VS (kind of wierd that the next page of the installer forces you to pick which version to install into, and you can't go on without picking a version). Debug still fails. Uninstall and the failure ceases to happen.

Visual Studio only fails when it hits a breakpoint. If I don't have breakpoints it seems to run fine. It seems like a strange thing that I could corrupt memmory that only matters when the IVF compiler is installed. Not impossible, but seems very unlikely since we haven't had evidence of a memory overwrite in this application for years.

Stilling installing and uninstalling to keep working.

Dave

Steve,

In addition to the above post I have tried the following. I uninstalled 11.1.060 and went back to 11.1.051. I have no problems debugging anything with 11.1.051 installed and integrated into VS2008. So it would appear something changed in 11.1.054 that has caused this issue. This problem started when I installed 11.1.060 directly from using 11.1.051. I had not tried 11.1.054 until after I couldn't use 11.1.060.

I also would still like to be able to uninstall 11.0.066. Does the check for another installer running come from Intel software, or from Windows Installer?

Dave

Steve Lionel (Intel)'s picture

Ok - that is getting interesting. If you remove just the Visual Studio integration and then delete the Intel Fortran folder under Visual Studio. does that change the behavior?

Next thing to try is to rename the Fortran LIB folder to LIBX and see if that makes a difference. I'm trying to identify what aspect of the compiler install is causing the problem.

Steve


Steve,

After removing the Intel Fortran folder I got the above message and VS crashes when hitting the breakpoint. I picked No to answer the form.

Just renaming the lib folder also resulted in a crash (after restoring the Intel Fortran folder).

Dave

Steve Lionel (Intel)'s picture

The install engineers suggest updating Windows Installer and then trying the uninstall again. I am rather doubtful that this will help, however.

Steve
Steve Lionel (Intel)'s picture

Ok - that tells me that the integration did not actually uninstall. Restore the folder. Open a Fortran command prompt window as administrator (right click on the shortcut and select Start as Administrator). cd to that Intel Fortran folder and then to the VFPaclkages subfolder. Type the following commands:

regsvr32 /s /u VFHieEditor.dll
regsvr32 /s /u VFAVwin.dll
regsvr32 /s /u VFFortSvc.dll
regsvr32 /s /u VFProjConvert.dll
regsvr32 /s /u VFProj.dll
regsvr32 /s /u VFToolOpt.dll

Now try your C++ program.

Steve

It still has the same error after unregistering those dll's.

Dave

Steve Lionel (Intel)'s picture

Yes. First, I'd like you to right click on one of them, select Properties, Details and note the File Version. Do that for the rest of them - they should all have the same file version and should say 11.1.3470.2008. If they don't, delete that folder and reinstall 11.1.060, then do the regsvr32 commands again to unregister them.

After you have done that, again start a command prompt as administrator and CD to that folder. Now, one at a time, do:

regsvr32 /s VFToolOpt.dll
regsvr32 /s VFProj.dll
regsvr32 /s VFProjConvert.dll
regsvr32 /s VFFortSvc.dll
regsvr32 /s VFAVwin.dll
regsvr32 /s VFHieEditor.dll

Stop after each one and try your C++ program. When you get to the one that triggers the error, let me know. I have a theory that you may find that the error has gone away.

Steve

sorry I did that last test with 11.1.051 installed instead of 11.1.060. And 11.1.051 works fine. So went back and installed 11.1.060 and then unregistered those dlls. It still crashes VS.

Dave

Steve Lionel (Intel)'s picture

Ok, then. With the DLLs unregistered, open VS and select Help > About. Is Intel Fortran mentioned under Additional Products?

Still with the DLLs unregistered, rename the LIB folder. Does the C++ app still crash? Is this an EXE you run or that gets run somehow?

Steve

There is no Intel mentioned in VS under Additional Products.

It still crashes with the DLLs unregistered and the library being called C:\Program Files (x86)\Intel\Compiler\11.1\060\libx

Note I didn't recompile or link my dll.So I wonder how renaming a library directory changesanything.So I also renamed the bin to binx. It still crashes even with that.

I run the AutoCAD 2010 acad.exe executable. That loads my dll (which actually has the suffix .arx).

Dave

Steve Lionel (Intel)'s picture

I wanted you to rename the LIB folder because that's where the Fortran run-time DLLs are. Is your DLL Fortran or C++? I'm trying to isolate the part of the Fortran install that is interfering. So far, I can't imagine what it would be.

Are you willing to attach a ZIP of your DLL? You can mark the reply private if you don't want others to see it.

Steve

I did the modify to remove the Parallel debugger, and it got an error, so I redid the modify with the "recommended settings" option in the window that opened.

Problem solved for me! Now why doesn't it work to have the parallel debugger installed? Problem for you guys!

Thanks for your help,

Dave

Steve Lionel (Intel)'s picture

It certainly is. Update 6 is available now from the Intel Registration Center, so please try that and let me know what happens.

Steve

Installing 11.1.065 including the Parallel debugger still causes VS to crash when it hits a breakpoint. Uninstalling the parallel debugger fixes the issue. Using Modify to uninstall the parallel debugger seems to end with it thinking it might not have uninstalled correctly. I check it uninstalled correctly this time and it seems okay.

Dave

Steve Lionel (Intel)'s picture

Ok, thanks. I am going to escalate this to the Parallel Debugger developers.

Steve

Steve,

Has this issue been resolved yet? I just installed on a new machine and got bit by it again.

Thanks,

Dave

Steve Lionel (Intel)'s picture

I believe the issue is resolved, though there is not yet a newer update. This seems to be an unusual issue though - it doesn't affect many people. Of course if you're one of them....

Which VS version are you using?

Steve

Visual Studio 2008

Login to leave a comment.