Problem with vtune 9.1

Problem with vtune 9.1

Hi, I'm using vtune but lately i have some problems with it.

All my computers are Linux Debian oriented.

On one of my computer ( core duo ) with 32 bit arch, i have no problems with runing vtune, before reinstalation debian i didnt have problem either on my secund computer ( Pentium D 830 x86_64). Unfortunately after reinstalation syatem and instalation vtune i recive some strange errors.

After command:

$ vtl activity -d 30 -c sampling -c callgraph -master sampling -app ./MY_APP run

I recive ERROR:

$ unable t o create environment file "./environment.xml" on xxx.xxx.xxx.xxx ( IP of my comp):[ERROR] unable to open SELI interface.

1) every log files look normal ( i guess ) and without errors i mean vtune_driver_compilation.log and vtune_install.log

2) problem probably is in vtserver becouse in user.log i have entry

vtserver.bin: [ERROR] unable to open SELI interface.

I was trying to "repare" it but i have no idea what is going on

Its is just trial version, but if i wont be able to use it its no sence to buy it.

If any body have clue what is going on please help.

regards

Luke

19 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Luke,

First at all, are you using logon user which is in "vtune" group?

Secondary, please ensure that you are using latest v9.1 Update 7 (build #370) which supports

Debian* 4 and 5
2.6.18-4 and 2.6.26-1

environment.xml could be created when running vtl command line (by the way, you have tospecify "-moi Myapp" for call graph data collection). I'm using "root" user, so environment.xml was created under "/root/VTune/Projects" after running vtl.

Other thing is that vtune driver should be loaded first, use "lsmod| grep vtune" to check. If not loaded, please goto "/opt/intel/vtune/vdk/src" torun "insmod-vtune", orrun "build-driver"

Regards, Peter

Hi, thank you for answer, unfortunately everything you said i already done.

1) root was in vtune group but to be sure i add:

$ usermod -g vtune root

2) I downloaded latest version of vtune from intel side and at begining of installation its written that it support Debian 5.0 ( im using 5.04 with kernel 2.6.26-2-amd64, on my laptop on which vtune works fine i have 2.6.26-2-686 ), but im not sure if its version 7. Im reading helps and other files inside /opt/intel/vtune to be sure ( I instaled vtune from vtun91_007_lin.tar.gz so its looks like 7th version )

3) module for my kernel was compiled and mounted proberly ( as i belive vtune_driver_compilation.log ) during istallation ( before of course i had prepared headers etc. in /usr/src/ catalog ) so instruction

$ lsmod | grep vtune => gives "vtune_drv"

4) ofcourse you are right ,shlud be "-moi Myapp" but with or without resoult is the same :):

ERROR: unable to create environment file ./environment.xml on xxx.xxx.xxx.xxx : [ERROR] unable to open SELI interface

Any way on both my computers ( with and without working vtune ) during boot time (or after starting /etc/inint.d/ntd) i have such information:

/etc/inint.d/ntd: start

chown: invalid user `sag:sag'

Regards

Luke

Quoting Luk And

Hi, thank you for answer, unfortunately everything you said i already done.

1) root was in vtune group but to be sure i add:

$ usermod -g vtune root

2) I downloaded latest version of vtune from intel side and at begining of installation its written that it support Debian 5.0 ( im using 5.04 with kernel 2.6.26-2-amd64, on my laptop on which vtune works fine i have 2.6.26-2-686 ), but im not sure if its version 7. Im reading helps and other files inside /opt/intel/vtune to be sure ( I instaled vtune from vtun91_007_lin.tar.gz so its looks like 7th version )

3) module for my kernel was compiled and mounted proberly ( as i belive vtune_driver_compilation.log) during istallation ( before of course i had prepared headers etc. in /usr/src/ catalog ) so instruction

$ lsmod | grep vtune => gives "vtune_drv"

4) ofcourse you are right ,shlud be "-moi Myapp" but with or without resoult is the same :):

ERROR: unable to create environment file ./environment.xml on xxx.xxx.xxx.xxx : [ERROR] unable to open SELI interface

Any way on both my computers ( with and without working vtune ) during boot time (or after starting /etc/inint.d/ntd) i have such information:

/etc/inint.d/ntd: start

chown: invalid user `sag:sag'

Regards

Luke

Hi Luke,

1) Actually "root" user will be automatically added to "vtune" group after installing the product, I meant to add common user to "vtune" group manually.

2)It is ok thatvtune driver has been loaded in your system.

3) Message "chown: invalid user `sag:sag' " can be ignored. It should have message "...ntdis already running" after doing "/etc/init.d/ntd start". You can try "/etc/init.d/ntd restart"

Last time, Ishould mention - environment.xmlshould becreated (for using"vtl") under "$user/VTune/Projects", that directory shouldNOT be network mapped, and have written-permission (if environment.xml is existed, delete it manually...vtl will recreate it)

Also "vtl version" helps to check product's version; "vtl query -lc" helps to check if sampling data collector is available.

If you NTD is damaged, vtserverstill works...so you can useremotely data collection (from another Linux* system). Otherwise, you need to reinstall the product.

Finally you have to install the product on local drive. Again - user home's directory should beat local drive as well.

Hope it helps.

Regards, Peter

Hi Peter.

"vtl version" say "Build: 401" and there is no 7 in all output so i gues that its version 4th, that would expain much :). My version was downloaded few days ago form intel server so it should be latest version, but it doesnt look like so where could i find version 7 th ?.

Information from "vtl query -lc" looks ok:

list of data collector available:

sampling

callgraph.

any way this error with "unable SELI ..." I recive when i start ANY

sampling activity, in grapical vtlec or comand line vtl. ( i reinstalled vtune few times and as i sais i read cerefully all .log files created by vtuna and i couldny find any error or worning massages ... every thing looks ok)

If you could give me link to 7th version ( this one form common intel server give me, as i mensioned 401 output and its ony one i could find till now on intel side ) i would try to install it.

Every thing is on local computer ( I could say thad instalation is canonical :) )

Regerds, Luke

Yes. Youare using latest v9.1 U7 - everything seems ok,sorry that I have no other idea.

I'm not sure for Debian 5.04, 2.6.26-2-686 for 32-bit can work on laptop, but 2.6.26-2-amd64 for 64-bit can't work.

Do you have other system for Debian* 5, 2.6.26-1 for testing? ThisOShas been testedon v9.1 U7.

Regards, Peter

hmm that sounds resonably.

Vtune on my laptop ( with Core Duo so kernel has to be 2.6.26-2-686 ) works ok, vtune on my stationary computer ( Pentium D 830, krenel ..-2-amd64 )doesn't works .. but few days ago i reinstaled debian to 5.04 version and from kernel ...-1-amd64 to ...-2-amd64. On ...-1-amd64 the same vtune wokred fine, so maybe problem is with kernel. If i will find some time i will try to serach problem within kernel, but it would take much more time im sure :). Sorry but I have change all of my sys to newest one, but a i saind -1-amd64 was ok

Regards, Luke

Hi Luke,

Additional info I got - I queriedother expertabout error message "unable to create environment file "./environment.xml" on xxx.xxx.xxx.xxx ( IP of my comp):[ERROR] unable to open SELI interface". This error message indicates VTune Analyzer's sampling collector was unable to create the above file, possibly due to ownership problem or insufficient disk space on the target file system.

Can you reproduce the problem by using sampling only? Like "vtl activity -d 20 -c sampling run".

Regards, Peter

Hi Peater. Unfortunately "vtl activity -d 20 -c sampling run" reproduce ERROR. Im running vtune as root so there shouldnt be problem witch permision, i dont think that its problem of insufficient dysk space either (more than 20GB free ). Im my /var/log/sys.log any time i start vtune i get:

======================================================
Feb 10 09:25:28 siemens vtlistenerd[26439]: VTune Performance Analyzer Remote Agent for Linux*
Feb 10 09:25:28 siemens vtlistenerd[26439]: Copyright (C) 2002-2008 Intel Corporation
Feb 10 09:25:28 siemens vtlistenerd[26439]: -- Remote Agent --------------
Feb 10 09:25:28 siemens vtlistenerd[26439]: server version: v9.1
Feb 10 09:25:29 siemens vtlistenerd[26439]: Incoming connection request: Session Id: 127.0.0.1-26436, User_Id: root, Client IP: 127.0.0.1 Arch: , Version: vt 9.0, protocol version 0.0
Feb 10 09:25:29 siemens vtlistenerd[26475]: Connection accepted
Feb 10 09:25:29 siemens vtserver.bin: [ERROR] unable to open SELI interface
Feb 10 09:25:29 siemens vtlistenerd[26439]: Killed.

So maybe SELI problem is primary and its descendant is "unable to create environment file "./environment.xml" on xxx.xxx.xxx.xxx ( IP of my comp)".

Thanks again or your help.

Regards, Luke


by the way ... what SELI stands for :), i guess that its not "mountainous-alpine village and winter sports resort located in the Vermion Mountains of northern Greece" or SeliTuners buiders company :)

The issue is so weird, it seemed your vtune driver is loaded, and log files are OK.

VTune Analyzer supports Pentium D processor, and kernel 2.6.26-1-amd64 works fine on your stationary computer, butkernel 2.6.26-2-amd64 (Debian* 5.04) does NOT work!

Is it possible that CPU information VTune Analyzer obtains from the system may have changed with the new kernel?

Comparing output of /proc/cpuinfo fromfirst kernel with that from kernel 2.6.26-2-amd64, may provide some clues.

Regards, Peter

P.S> Thanks for useful URLs, especially I like many village views in differentcountries:-)

no problem i can send you more ;-), ( i just copy from Wiki desctription of Sei vilage :) ), but its interesting what SELI inteface means ??, i couldn't find in internet except vilage in greece and some "diggers" company :).

Regard, Luke

I run into the same problem on RHEL 5.4 (kernel 2.6.18-164.el5) with vtune91_007_lin.tar.

Installation is OK, vtl query lc is OK

Please help, this is very important.

BTW, I experienced no problem on RHEL 5.3.

In my experience, after such an update to the OS (and probably allowing VTune to rebuild its driver) you may have to remove all user data directories (workspace and /home/yourhome/.vt*). In any case, the old data collections become unuseable.

I am also running into this issue with my VTune install. The system is currently running SLES 11 with a custom kernel of2.6.27.19-5

The driver seems to compile and install fine. But when trying to run sampling Ireceivethe same error:

$unable to create environment file "./environment.xml" on xxx.xxx.xxx.xxx ( IP of my comp):[ERROR] unable to open SELI interface.

No ideas on what might the issue be? I've used VTune previously on a separate machine but I do not think it was 9.1U7

Thanks,

Simon

Quoting tim18
In my experience, after such an update to the OS (and probably allowing VTune to rebuild its driver) you may have to remove all user data directories (workspace and /home/yourhome/.vt*). In any case, the old data collections become unuseable.

Thanks to tim18.

Both RHEL 5.4 and SLES 11 should be supported on latest v9.1 Update 7.

After uninstalling prior product, please manually delete old VTune directory (default is /opt/intel/VTune), workspace directory (default is $user/workspace), user vtune directory (for "vtl" command, default is /user/VTune). Then install new product.

But butkernel 2.6.26-2-amd64 (Debian* 5.04) still bethe problem for v9.1 U7, please usekernel 2.6.26-1-amd64 (Debian* 5), or wait for next update of the product.

Regards, Peter

Quoting Peter Wang (Intel)

But butkernel 2.6.26-2-amd64 (Debian* 5.04) still bethe problem for v9.1 U7, please usekernel 2.6.26-1-amd64 (Debian* 5), or wait for next update of the product.

I had exactly the same error "SELI Interface" on my debian 5.0.4 64 bits. Only the Callgraph was working in VTune. Moving back to kernel 2.6.26-1-amd64 solved the problem and I can now run Sample Wizzard.

Thx for this thread.

Hi all,

I had exactly the same error "SELI Interface" on my debian 5.0.4 (2.6.26-2-amd64).

I would like to know if there is a new version of VTune wich works with my kernel version, or if I must to downgrade my kernel to 2.6.26-1-amd64 ?

Thx

I have installed the kernel 2.6.26-1-amd64, and now it works ...

Leave a Comment

Please sign in to add a comment. Not a member? Join today