11.1 Install fails with "Invalid directory" message on default install options

11.1 Install fails with "Invalid directory" message on default install options

We are currently upgrading our tools to 11.1.051 and for most developers the install was a breeze. 2 developers have an issue where they are not able to install to the default "C:\Program Files\Intel" folder. The installer states that it is an invalid directory. This is even after the installer extracts all the files into the \download folder.
All antivirus is Off. Simple File sharing is off. System has been rebooted. Other apps install fine to the Program Files folder. Installer has Admin privileges
I saw one other occurance of this sort of behaviour on the Fortran forum with 11.1 but there was no resolution listed there.
Any ideas ?

Dev Env
----------
VS2008 SP1 on Windows XP Professional with SP3

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Jennifer J. (Intel)'s picture

did you install with "Complete" installation type or "Custom" installation type?

Jennifer

Jennifer J. (Intel)'s picture

Another question is when you get the error msg about "c:program files ..." like which steps, what is displayed on the installation dialog?

or could you send a screen-shot of the error dlg and the installation dlg?

Thanks,
Jennifer

Quoting - Jennifer Jiang (Intel)


Another question is when you get the error msg about "c:program files ..." like which steps, what is displayed on the installation dialog?

or could you send a screen-shot of the error dlg and the installation dlg?

Thanks,
Jennifer

Both standard and custom instll options tried.

Here's the installation log. Anything else we can supply ?

Attachments: 

AttachmentSize
Download C_2B_2BProfessional.Log7.58 MB

Depending on your Windows version, you may actually have to log in as administrator to install the compiler. So far, my experience with Windows 7 is a welcome change from that situation.

Jennifer J. (Intel)'s picture

Quoting - Nikhil Deshpande
Here's the installation log. Anything else we can supply ?

do you have a "D:" drive? is there another OS on "D:"?

Jennifer

Quoting - Jennifer Jiang (Intel)

do you have a "D:" drive? is there another OS on "D:"?

Jennifer

Will check and get back to you. Most of our developers have an external drive where their code is but no software installs on that drive. The developers with the issue are not on-site so there's a little lag before I get answers from them.
What should I be asking them to check for ?

Jennifer J. (Intel)'s picture

Quoting - Nikhil Deshpande

Will check and get back to you. Most of our developers have an external drive where their code is but no software installs on that drive. The developers with the issue are not on-site so there's a little lag before I get answers from them.
What should I be asking them to check for ?

I've also sent this bug with log file to our compiler's installation team to investigate. The log file shows the target drive is "D:". It's a bug that the installation sets target drive as "D:". But it must be come from somewhere and the log file didn't say that. orI didn't find it. so I'mwondering if you're using "D:" for anything.

I'll get back to you when I learn more about this from the log file.

Jennifer

Quoting - Nikhil Deshpande
I have tried to load this on to a Windows XP 32 bit machine and it gives the access denied. I've tried my Windows 7 laptop (which I wanted to use to port my old Fortran 2000 projects before I put them on my workstation. Microsoft Visual Studio 2008 goes on fine on all machines. It's the Intel Fortran that has been nothing but a hassle. I've tried to contact "support" but was ignored. I've never had software that just refuses to load. It's the only one.

Randwulf

We are currently upgrading our tools to 11.1.051 and for most developers the install was a breeze. 2 developers have an issue where they are not able to install to the default "C:Program FilesIntel" folder. The installer states that it is an invalid directory. This is even after the installer extracts all the files into the download folder.
All antivirus is Off. Simple File sharing is off. System has been rebooted. Other apps install fine to the Program Files folder. Installer has Admin privileges
I saw one other occurance of this sort of behaviour on the Fortran forum with 11.1 but there was no resolution listed there.
Any ideas ?

Dev Env
----------
VS2008 SP1 on Windows XP Professional with SP3

Jennifer J. (Intel)'s picture

Quoting - randwulftech
I have tried to load this on to a Windows XP 32 bit machine and it gives the access denied. I've tried my Windows 7 laptop (which I wanted to use to port my old Fortran 2000 projects before I put them on my workstation. Microsoft Visual Studio 2008 goes on fine on all machines. It's the Intel Fortran that has been nothing but a hassle. I've tried to contact "support" but was ignored. I've never had software that just refuses to load. It's the only one.

Randwulf

Hi Randwulf,
Yeh, I can understand the frustration. Sorry for such inconvenience.

This issue is being fixed as we speak now. For now, please use "Custom" installation type, and entry a directory that is not "c:program files".

Thanks,
Jennifer

Jennifer J. (Intel)'s picture

FYI. This issue has been fixed for a while since update 5.

Please post here if it is still an issue for you and thanks,
Jennifer

Login to leave a comment.