problem with installing cilk++

problem with installing cilk++

hi every one,
iam a novice working on cilk++. i had a problem with installing and running the cilk++examples on my test system. i performed the following steps as mentioned in the cilk++ release notes
1. Idownloaded cilk++ 64-bit software cilk_8503-x86_64.release.tar.gz.
2. unzipped to my home directory /home2/chow../ and a folder was created /home2/chow../cilk
3. i set the path using the command PATH= /home2/chow../cilk/bin:$PATH.
4. next i changed to the examples directory cd /home2/scra07/cilk/examples/qsort.
5. i tried to build and run the program using the command make.
after this iam getting a problem i couldn't see anymessage or output(or)some times iam getting amessage like"make: Nothing to be done for `all'." .
Could any one please help me with this problem.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Best Reply

Hi. Thanks for trying Cilk++. Unfortunately, I cannot reproduce your problem. Can you try reproducing the
following commands and posting the output in this forum so that I can take a look? Thanks.

$ cd /tmp
$ tar xzpf ~/Download/cilk_8503-x86_64.release.tar.gz
$ export PATH=$PWD/cilk/bin:$PATH
$ cd cilk/examples/qsort
$ make
cilk++ qsort.cilk -O1 -g -lcilkutil -o qsort
$ ./qsort
Sorting 10000000 integers
0.32 seconds
Sort succeeded.
$ CILK_NPROC=1 ./qsort
Sorting 10000000 integers
2.021 seconds
Sort succeeded.
$

Quoting - Matteo Frigo (Intel)

Hi. Thanks for trying Cilk++. Unfortunately, I cannot reproduce your problem. Can you try reproducing the
following commands and posting the output in this forum so that I can take a look? Thanks.

$ cd /tmp
$ tar xzpf ~/Download/cilk_8503-x86_64.release.tar.gz
$ export PATH=$PWD/cilk/bin:$PATH
$ cd cilk/examples/qsort
$ make
cilk++ qsort.cilk -O1 -g -lcilkutil -o qsort
$ ./qsort
Sorting 10000000 integers
0.32 seconds
Sort succeeded.
$ CILK_NPROC=1 ./qsort
Sorting 10000000 integers
2.021 seconds
Sort succeeded.
$

Hi,
Thanks for the Reply. your sequence of commands works. Now i got the same out put as u mentioned. Actually i understand i tried a wrong command for setting the path before, also i missed the command to run the program. But now its ok. Very very thanks for the reply.

Quoting - chowdarys

Hi,
Thanks for the Reply. your sequence of commands works. Now i got the same out put as u mentioned. Actually i understand i tried a wrong command for setting the path before, also i missed the command to run the program. But now its ok. Very very thanks for the reply.

thanx I use..

Leave a Comment

Please sign in to add a comment. Not a member? Join today