Lost ability to compile using X64 for 64 bit platforms.

Lost ability to compile using X64 for 64 bit platforms.

I'm running IVF version 11 on Windows XP, on a 32 bit machine. I've been compiling for both 32 bit and 64 bit PCs. I recently began getting the error "Intel Fortran Compiler for 'x64' not installed". The most recent 64 bit executable I have built is from July 1st. I can compile 32 bit executables with no problem. I haven't made any changes to my PC, but my IT seems to push through updates every couple of days, so who knows what they may have changed.

I've tried modifying the install, and repairing the install, using the install disk, with no luck. I haven't tried uninstalling and reinstalling, because I can't just uninstall the 64 bit compiler, I seem to have to uninstall everything, and I'm worried I will lose all my settings.

Possibly relevant: If I go to Tools -> Options -> Intel Fortran -> Compilers, under the Target Platform dropdown, only win32 is available. I've never looked at this page before, so I don't know if x64 should also be an option, but it seems like it should. There's only one Selected Compiler option as well (Intel Fortran 11.0.061 [IA32]).

x64 and win32 both show up as Active solution platform options in the configuration manager.

Any ideas on how to get x64 working again with a minimum of hassle?

ETA: I'm running in the MS Visual Studio 2008 IDE, and have been for close to a year.

30 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Steve Lionel (Intel)'s picture

Download the "Intel 64" compiler (filename ends in _intel64.exe) from the Intel Registration Center and install it.

You can also try doing a Change from Add or Remove Programs and then select Modify to see if you can add the Intel 64 compiler. Or, if it says it is installed, try Repair.

Steve

Quoting - Steve Lionel (Intel)
Download the "Intel 64" compiler (filename ends in _intel64.exe) from the Intel Registration Center and install it.

You can also try doing a Change from Add or Remove Programs and then select Modify to see if you can add the Intel 64 compiler. Or, if it says it is installed, try Repair.

I did this, and installed w_cprof_p_11.0.075_intel64.exe, but I still can't compile for x64. Same error. It said the installation completed normally. I also still only have Win32 as an option for the Target Platform in the Options dialog.

If I run w_cprof_p_11.0.075_intel64.exe again, and select Modify, it shows the Space Required for all components as 0, which I assume means they are installed.

Under Add or Remove Programs, my only option is to uninstall. I have tried both the Modify and Repair options when I run setup.exe on the install CD (DVD?).

Steve Lionel (Intel)'s picture

You have to add x64 as a new target platform for your solution.

Build > Configuration Manager. Under Active Solution Platform, select New. When the New Solution Platform window comes up, click OK.

Does this help any?

Steve

Quoting - Steve Lionel (Intel)

You have to add x64 as a new target platform for your solution.

Build > Configuration Manager. Under Active Solution Platform, select New. When the New Solution Platform window comes up, click OK.

Does this help any?

x64 already is a target platform in the configuration manager. I can't add it again, I can't leave the new platform name blank, and I can't put in a dummy name. I tried adding it to another Fortran code, but I get the same error as above.

I've been compiling for x64 all along, as recently as July 1st. Sometime between then and yesterday, it stopped working, and I don't know why.

Steve Lionel (Intel)'s picture

If you uninstall and reinstall the compiler, I don't think it will affect your settings, though I can't promise that. It won't affect your project properties.

If in VS you go to Tools > Options > Intel Visual Fortran > Compilers, can you select x64 as a platform? (Note - this dialog just controls where the x64 compiler is looked for, it does not "select" x64 as a platform for your projects.)

Next thing to look at - with the solution open, select Build > Configuration Manager. Select x64 as the active solution platform. Does your project show x64 in the Platform column?

Steve

Quoting - Steve Lionel (Intel)
If you uninstall and reinstall the compiler, I don't think it will affect your settings, though I can't promise that. It won't affect your project properties.

If in VS you go to Tools > Options > Intel Visual Fortran > Compilers, can you select x64 as a platform? (Note - this dialog just controls where the x64 compiler is looked for, it does not "select" x64 as a platform for your projects.)

Next thing to look at - with the solution open, select Build > Configuration Manager. Select x64 as the active solution platform. Does your project show x64 in the Platform column?

No, I can't select x64 as a platform in tools -> Options -> IVF -> Compilers. I mentioned this in my OP. Only Win32 is available.

In Build -> Configuration Manager, I can select x64 as an Active solution platform, and I have x64 in the platform column.

Steve Lionel (Intel)'s picture

In that case, I am going to recommend an uninstall and reinstall of the compiler. If you're doing that, you may as well download the latest version available to you from the Intel Registration Center.

Steve

Quoting - blischke

No, I can't select x64 as a platform in tools -> Options -> IVF -> Compilers. I mentioned this in my OP. Only Win32 is available.

In Build -> Configuration Manager, I can select x64 as an Active solution platform, and I have x64 in the platform column.

I have a Windows Vista 64bit OS, Visual Studio 2005 and Intel Fortran 10.3 and also get the same "x64" Fortran not installed. I installed only the 64bit version of the Intel Fortran and tried to compile the x64 target in Visual Studio 2005. So I would also like to know what is going on.

Steve Lionel (Intel)'s picture

Quoting - giovanni.fusinadrdc-rddc.gc.ca

I have a Windows Vista 64bit OS, Visual Studio 2005 and Intel Fortran 10.3 and also get the same "x64" Fortran not installed. I installed only the 64bit version of the Intel Fortran and tried to compile the x64 target in Visual Studio 2005. So I would also like to know what is going on.

When you say you installed "the 64bit version", what was the filename of the download you installed? If it ended in _ia64.exe, you got the wrong one. You want one that ends in _intel64.exe. I'm also not sure which version you have, since we have not released a 10.3.

Steve

Quoting - Steve Lionel (Intel)

When you say you installed "the 64bit version", what was the filename of the download you installed? If it ended in _ia64.exe, you got the wrong one. You want one that ends in _intel64.exe. I'm also not sure which version you have, since we have not released a 10.3.

w_fc_0_10.1.030_intel64.exe (P.S. it would help if both Intel and Windows would be consistent with their naming since Windows calls their platform x64 not Intel64 or IA64).

Quoting - giovanni.fusinadrdc-rddc.gc.ca

w_fc_0_10.1.030_intel64.exe (P.S. it would help if both Intel and Windows would be consistent with their naming since Windows calls their platform x64 not Intel64 or IA64).

Another interesting not when the 32 bit vesrion wasn't installed you get a different type message. Instead of a window popping up when you compiler for win32 platform you get a message about can not find the ifort.exe file. These seems to me like the message you should see if you didn't have the 64bit version of the Intel Fortran compiler installed and tried to compile for the "x64' platform.

Steve Lionel (Intel)'s picture

I have a vague recollection that for 10.1, you needed to have the IA-32 compiler installed also, even if you were not going to use it. That went away in 11.0. 11.1 is current.

As for the naming, I wish we could use "x64", but the corporate branding folks have other ideas.

Steve

I orginally had both win32 and intel64 version of the compiler installed and only win32 platform would compile. I would get the same popup window with the message Intel Fortran Compiler not installed for 'x64' message window when i tried to compile for x64 in visual studio 2005. I only deinstalled both versions and installed the intel64 only version to isolate the problem. When i had both version installed I saw both the 32bit and 64bit versions of the compile in the control panel/program. Like the gentleman who original posted i to wanted to compile for both versions but I am trying everything at the momment to get the 64bit version to work (32bit version works fine).

Steve Lionel (Intel)'s picture

Let's try this. Start >Run. Enter REGEDIT and click OK. Click on the + signs next to the following names, in order: HKEY_LOCAL_MACHINE, Software, Intel, Compilers, Fortran. Click the + next to the version number of the compiler you're trying to use. Is there an "EM64T" subkey?

Next, go back into Visual Studio. Select Tools > Options > Intel Visual Fortran > Compiler. For the compiler version, make sure it says the same version that you have installed. (With 11.1, you can say "".)

Steve

Quoting - Steve Lionel (Intel)
Let's try this. Start >Run. Enter REGEDIT and click OK. Click on the + signs next to the following names, in order: HKEY_LOCAL_MACHINE, Software, Intel, Compilers, Fortran. Click the + next to the version number of the compiler you're trying to use. Is there an "EM64T" subkey?

Next, go back into Visual Studio. Select Tools > Options > Intel Visual Fortran > Compiler. For the compiler version, make sure it says the same version that you have installed. (With 11.1, you can say "".)

I am not sure it is because I am running Vista and the registry is different, but there is no compiler subdirectory after Intel in the HKEY_LOCAL_MACHINE. There is a IA32_EM64T entry (under 101.300 directory) under Visual Studio 8 under Intel Fortran Compiler in the HKEY_CURRENT_USER folder (i didn't include the intermediate subfolder names).

When I went into Tools > Options > Intel Fortran > Compiler in Visual Studio 2005 the only target platfrom was Win32 and it said it was not installed (this is true cause I uninstalled it and installed the Intel64 version only). I do not have an x64 option. It appears that the the Fortran Integration for Visual Studio 2005 didn't not add it correctly. So I to see the same thing as the original poster but for different versions of visual studio and intel fortran that only the Win32 target is available in Tools > Options > Intel Fortran > Compiler.

Do you want me to install both versions of the Intel compiler again?

Steve Lionel (Intel)'s picture

Please install the compiler package with a name ending in _novsppe.exe, after uninstalling all instances of Intel Visual Fortran you can find in Add/Remove Programs.

Steve

Quoting - Steve Lionel (Intel)
In that case, I am going to recommend an uninstall and reinstall of the compiler. If you're doing that, you may as well download the latest version available to you from the Intel Registration Center.

OK, I did this. I downloaded w_cprof_p_11.0.075_novsppe.exe, uninstalled w_cprof_p_11.0.075_intel64.exe and uninstalled the IVF I had been using, then ran w_cprof_p_11.0.075_novsppe.exe to install.

Nothing has changed (except that all the files are in subdirectories of 075 instead of subdirectories of 061). I get the same error message I reported in my OP. I still do not have x64 available as a dropdown in the Tools -> Options -> etc. tab. (The Win32 compiler is now the 075 version, instead of the 061 version, so the install worked.)

Is there something that has to be done to tell either MS Visual Studio 2008 or IVF that there is another platform it should be supporting?

ETA: In the directory C:Program FilesIntelCompiler11.075fortranBin there are two subdirectories, IA32, and IA32_Intel64. Is the second one the x64 compiler? There's pretty much the same stuff in the two of them by name (file sizes and times are different), so it seems to be there.

Steve Lionel (Intel)'s picture

Yes, the second one is the x64 compiler.

Try running the attached program. If this doesn't work, I'd like to arrange a time where I can connect to your system and "look around". If this is possible, please send me an email to steve.lionel at intel.com and let me know when you'd be available and your timezone.

Steve

Quoting - Steve Lionel (Intel)
Yes, the second one is the x64 compiler.

Try running the attached program. If this doesn't work, I'd like to arrange a time where I can connect to your system and "look around". If this is possible, please send me an email to steve.lionel at intel.com and let me know when you'd be available and your timezone.

No luck.

I ran the program, but still no x64 in the Target Platform dropdown, and the same error message when I try to compile.

I don't think there's any way I'd be able to get approval to let a non-employee to connect to my system. Is there any thing I could look for?

Steve Lionel (Intel)'s picture

blischke, I'm going to suggest that you start over. Uninstall Intel Visual Fortran and Microsoft Visual Studio. Reinstall Visual Studio, selecting a Custom install and making sure that the C++ x64 support is installed, like this:

When done with this, install the _novsshell.exe version of Intel Visual Fortran.

Steve

Quoting - Steve Lionel (Intel)
blischke, I'm going to suggest that you start over. Uninstall Intel Visual Fortran and Microsoft Visual Studio. Reinstall Visual Studio, selecting a Custom install and making sure that the C++ x64 support is installed, like this:

[snip]

When done with this, install the _novsshell.exe version of Intel Visual Fortran.

It's working! I didn't have to uninstall it, I just ran autorun.exe on the MS Visual Studio install DVD. I thought I might get an option to repair, but I didn't see any options for Custom Install, Repair, or anything.

I've got a link error for mkl_something.lib, but I can probably track that one down.

Thanks.

Steve Lionel (Intel)'s picture

Weird... But I'm glad you're back in business.

Steve

Quoting - Steve Lionel (Intel)
Weird... But I'm glad you're back in business.

I thought I could figure this out, but I can't. It's complaining that it can't open mkl_intel_c.lib. I have that file, but it's in C:Program FilesIntelCompiler11.075fortranmklia32lib. There is no corresponding MKL directory with ...ia32_intel64lib, or ...intel64lib. Theres a directory ...em64tlib, but it doesn't have a file with that name.

Do I just add the ...ia32lib directory to the library paths? That doesn't seem right.

I remember that it was very difficult to figure out which files to link to for running the MKl when I first got it. In the Properties -> Linker -> Input -> Additional Dependencies for the project I'm trying to compile, I have listed the libraries mkl_intel_c.lib mkl_sequential.lib mkl_core.lib. I don't remember how these were determined.

Steve Lionel (Intel)'s picture

What is referencing mkl_intel_c.lib? That's not a correct name for Intel 64. Here's what the documentation says:

Intel 64 and IA-64 architectures, static linking
mkl_intel_ lp64.lib mkl_intel_ thread_lp64.lib mkl_core.lib libiomp5md.lib
Intel 64 and IA-64 architectures, dynamic linking
mkl_intel_ lp64_dll.lib mkl_intel_ thread_lp64_ dll.lib mkl_core_dll. lib libiomp5md.lib

Steve

Quoting - Steve Lionel (Intel)
What is referencing mkl_intel_c.lib? That's not a correct name for Intel 64. Here's what the documentation says:

Intel 64 and IA-64 architectures, static linking
mkl_intel_ lp64.lib mkl_intel_ thread_lp64.lib mkl_core.lib libiomp5md.lib
Intel 64 and IA-64 architectures, dynamic linking
mkl_intel_ lp64_dll.lib mkl_intel_ thread_lp64_ dll.lib mkl_core_dll. lib libiomp5md.lib

I think I overwrote the x64 configuration properties with the win32 configuration properties when I was trying to get the x64 compiler to be found. I changed imkl_intel_c.lib to mkl_intel_lp64.lib, and fixed some other things that were using the win32 properties, and I got it to compile and link. Thanks again.

No idea if it will run yet...

Quoting - blischke

I think I overwrote the x64 configuration properties with the win32 configuration properties when I was trying to get the x64 compiler to be found. I changed imkl_intel_c.lib to mkl_intel_lp64.lib, and fixed some other things that were using the win32 properties, and I got it to compile and link. Thanks again.

No idea if it will run yet...

I still did not get Visual Studio 2005 for Window Vista 64bit to comile for the x64 version. I am using Intel Visual FORTRAN 10.1 (build 30). I couldn't use the version 11 of the program you asked us to download andtry, but I first tried to repair the Visual Studio 2005 running the setup.exe for Visual Studio and selecting the repair option. That didn't work so I unistalled the Intel FORTRAN compiler and installedw_fc_p_10.1.030_novsppe (suppose to have have both 32 and 64 bitversions which I saw with custom install). Still the x64 platform target does not show up in Visual Studio and I can'tcompile for64bit version (x64). I can compile for win32 target platform though. Not sure how the original poster got his x64 target back.

Steve Lionel (Intel)'s picture

If the x64 target does not show up in Visual Studio, that suggests you don't have the x64 support installed. Please go through these steps:

If you are using Visual Studio 2005/2008 Standard Edition or or Visual Studio 2005 Premier Partner Edition or Visual Studio 2008 Shell, no
configuration is needed to build Intel 64 architecture applications. For other editions:
1. From Control Panel > Add or Remove Programs, select Microsoft Visual Studio 2005
(or 2008) > Change/Remove. The Visual Studio Maintenance Mode window will appear.
Click Next.
2. Click Add or Remove Features
3. Under Select features to install, expand Language Tools > Visual C++
4. If the box X64 Compiler and Tools is not checked, check it, then click Update. If the
box is already checked, click Cancel.

Steve

Quoting - blischke

I think I overwrote the x64 configuration properties with the win32 configuration properties when I was trying to get the x64 compiler to be found. I changed imkl_intel_c.lib to mkl_intel_lp64.lib, and fixed some other things that were using the win32 properties, and I got it to compile and link. Thanks again.

No idea if it will run yet...

I reinstalled Visual Studio 2005 (custom install enablingVisual C++/x64 Compiler and Tools option) and Intel Visual Fortran (win32 and x64 novsppe version). Seems it will not create an x64 target without enabling the Visual C++/x64 Compiler and Tools. Itnow will compile for x64 platform.

Steve Lionel (Intel)'s picture

That is correct and is called out in the release notes. I'm glad to hear that you got it working.

Steve

Login to leave a comment.