"Unable to Start Program" Error

"Unable to Start Program" Error

Hi all,
I suddenly started to have this Windows OS message "Unable to Start Program ..." when I try to run a program that was successfully compiled. I was not having this message before, and as far as I know I did not do anything different this time. I wonder if anybody has a clue of what could be causing this error. Please let me know if you need further information.
Many thanks,
Rafael

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Please show the build log output from your build. I wonder if you have built a 64-bit application and are running it on 32-bit Windows.

Steve

Quoting - Steve Lionel (Intel)
Please show the build log output from your build. I wonder if you have built a 64-bit application and are running it on 32-bit Windows.

Hi Steve,

Here it is.

Thanks,
Rafael

Build Log
Build started: Project: Simple_eq, Configuration: Debug|Win32

Output
Deleting intermediate files and output files for project 'Simple_eq', configuration 'Debug|Win32'.
Compiling with Intel Fortran 11.0.061 [IA-32]...
ifort /nologo /debug:full /Od /gen-interfaces /warn:interfaces /module:"Debug" /object:"Debug" /traceback /check:bounds /libs:static /threads /dbglibs /c /Qvc8 /Qlocation,link,"C:Program FilesMicrosoft Visual Studio 8VCbin" "C:Documents and SettingsrdcMy DocumentsResearchMobility CostsNew Fortran CodesSimple EquilibriumMany Cohorts Many SectorsGlobal_Data.F90"
ifort /nologo /debug:full /Od /gen-interfaces /warn:interfaces /module:"Debug" /object:"Debug" /traceback /check:bounds /libs:static /threads /dbglibs /c /Qvc8 /Qlocation,link,"C:Program FilesMicrosoft Visual Studio 8VCbin" "C:Documents and SettingsrdcMy DocumentsResearchMobility CostsNew Fortran CodesSimple EquilibriumMany Cohorts Many SectorsCalc_Emax.F90"
ifort /nologo /debug:full /Od /gen-interfaces /warn:interfaces /module:"Debug" /object:"Debug" /traceback /check:bounds /libs:static /threads /dbglibs /c /Qvc8 /Qlocation,link,"C:Program FilesMicrosoft Visual Studio 8VCbin" "C:Documents and SettingsrdcMy DocumentsResearchMobility CostsNew Fortran CodesSimple EquilibriumMany Cohorts Many SectorsMain.F90"
Linking...
Link /OUT:"DebugSimple_eq.exe" /INCREMENTAL:NO /NOLOGO /MANIFEST /MANIFESTFILE:"C:Documents and SettingsrdcMy DocumentsVisual Studio 2005ProjectsSimple_eqSimple_eqdebugsimple_eq.exe.intermediate.manifest" /DEBUG /PDB:"C:Documents and SettingsrdcMy DocumentsVisual Studio 2005ProjectsSimple_eqSimple_eqdebugsimple_eq.pdb" /SUBSYSTEM:CONSOLE /IMPLIB:"C:Documents and SettingsrdcMy DocumentsVisual Studio 2005ProjectsSimple_eqSimple_eqdebugsimple_eq.lib" "DebugGlobal_Data.obj" "DebugCalc_Emax.obj" "DebugMain.obj"
Link: executing 'link'

Embedding manifest...
mt.exe /nologo /outputresource:"C:Documents and SettingsrdcMy DocumentsVisual Studio 2005ProjectsSimple_eqSimple_eqdebugsimple_eq.exe;#1" /manifest "C:Documents and SettingsrdcMy DocumentsVisual Studio 2005ProjectsSimple_eqSimple_eqdebugsimple_eq.exe.intermediate.manifest"

Simple_eq - 0 error(s), 0 warning(s)

Are you trying to start this in the debugger? Which Visual Studio version are you using? Will the program run if you use "start without debugging"?

A web search suggests many causes for this error, including a virus.

What is the exact text of the error message? Can you attach a ZIP of the EXE here?

Steve

Quoting - Steve Lionel (Intel)
Are you trying to start this in the debugger? Which Visual Studio version are you using? Will the program run if you use "start without debugging"?

A web search suggests many causes for this error, including a virus.

What is the exact text of the error message? Can you attach a ZIP of the EXE here?

Yes, I am trying to start the debugger. I am using Visual Studio 2005 8.0.
The message I received is: Unable to start program 'C:/..../simple_eq.exe'
When I try to 'start without debugging' I receive: 'C"/.../simple_eq.exe' is not a valid Win32 application.
I receive the same error message when I build the project in release mode and try to execute it.
The zip of the exe file is attached.
Should I uninstall and then install again both MVS and Intel Fortran?
Thanks a lot,
Rafael

Best Reply

Do you declare a very large array in the program? It looks as if the "data size" is too large to run on 32-bit Windows, though it does not quite exceed 2GB. I see no evidence that there is a compiler problem. The data section has size X'7CD88980'.

Steve

Quoting - Steve Lionel (Intel)
Do you declare a very large array in the program? It looks as if the "data size" is too large to run on 32-bit Windows, though it does not quite exceed 2GB. I see no evidence that there is a compiler problem. The data section has size X'7CD88980'.

Hi Steve,
You are probably right. I increased an array in a factor of 10 just before I got this problem.
However, I cannot be sure yet. I have a new problem now.
I decided to uninstall and the reinstallthe latest versiobs of Intel Fortran and MS Visual Studio. I first received an error message such as "cannot find rc.exe".
I then followed the procedure in http://software.intel.com/en-us/articles/can-not-find-rcexe/
Now, when I try to build a project a get the error message:
fatal error LNK1104: cannot open file 'mkl_intel_c.lib'
Could you please help me on that?
Many thanks,
Rafael

Quoting - rafadix08

Hi Steve,
You are probably right. I increased an array in a factor of 10 just before I got this problem.
However, I cannot be sure yet. I have a new problem now.
I decided to uninstall and the reinstallthe latest versiobs of Intel Fortran and MS Visual Studio. I first received an error message such as "cannot find rc.exe".
I then followed the procedure in http://software.intel.com/en-us/articles/can-not-find-rcexe/
Now, when I try to build a project a get the error message:
fatal error LNK1104: cannot open file 'mkl_intel_c.lib'
Could you please help me on that?
Many thanks,
Rafael

I guess this is relevant information...
I have the following lines in my program (I use the IMSL library)

INCLUDE 'link_fnl_static_hpc.h'
USE RNNOR_INT
USE RLSE_INT

Select Tools > Options > Intel Visual Fortran > Compilers. Click the "..." button next to Libraries. It should contain this line somewhere in the list:

$(IFortInstallDir)mklia32lib

If it doesn't, add it.

Steve

Login to leave a comment.