Icc with QNX 6.4.1 ?

Icc with QNX 6.4.1 ?

Hi,

Is there a version of the Intel compiler that is compatible with QNX 6.4.1 ?
The package I installed, V1107, is compatible with QNX 6.3.2, which is now 2 releases back from current.

I found that Momentics 6.4.1 recognized that the compiler was installed, and offered it as a compiler option, but when trying to use it, it failed to find the file: i386-pc-nto-qnx6.3.0-g++.exe. I found this file in my Momentics 6.3.2 install tree, and copied it to my 6.4.1, in the same subdirectory, but it still fails to find it.

Am I using the wrong software, or are there plans to update it ?

Thanks !

Dave (QNX FAE)

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Dave,
the upcoming release (early July) of the Intel C++ Compiler 11.1 Professional Edition for QNX* Neutrino* RTOS will support installation into Momentics 6.4.0 and a later update also 6.4.1.
I'll leave it to my specialist colleague to reply with more details when he's back in the office on Monday.
Regards, Thomas

Quoting - David Bott
Hi,

Is there a version of the Intel compiler that is compatible with QNX 6.4.1 ?
The package I installed, V1107, is compatible with QNX 6.3.2, which is now 2 releases back from current.

I found that Momentics 6.4.1 recognized that the compiler was installed, and offered it as a compiler option, but when trying to use it, it failed to find the file: i386-pc-nto-qnx6.3.0-g++.exe. I found this file in my Momentics 6.3.2 install tree, and copied it to my 6.4.1, in the same subdirectory, but it still fails to find it.

Am I using the wrong software, or are there plans to update it ?

Thanks !

Dave (QNX FAE)

Hi Dave,

I can only confirm what Thomas mentioned for a couple of days ago. Therewere several changed we had to make to the compiler installation to get it to work with SDP6.4.0. There is a Beta version of this compiler available now on Intel Premier Support. The release which we expect to have ready early July will support SDP6.4.0.When this release is ready we will start working on SDP6.4.1 support.

Thanks,
Bernth

Leave a Comment

Please sign in to add a comment. Not a member? Join today