mpi on Vista 64 mapped drive

mpi on Vista 64 mapped drive

johnappleyard377's picture

Running on a shared memory machine, and in a current directory j:\myprog - where J: is mapped tp c:\users\john\documents, I discovered that all the mpi instances report the current directory as c:\windows\system32. After some hair loss, I tried switching to the canonical directory - c:\users\john\documents\myprog - and it works. It also works if I use -wdir to specify the canonical directory, but not if I use the mapped drive with -wdir.

Is this a bug?

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Gergana Slavova (Intel)'s picture
Best Reply

Hi johnappleyard377,

I would suggest using the -mapall version for the Intel MPI Library for Windows*. This should create the user-mapping of the C:usersjohndocuments on all nodes of the cluster. There are no arguments for this option, simply add "-mapall" to your mpiexec command line:

mpiexec -mapall j:myprog

More info is available in the Intel MPI Library Reference Manual available in the docfolder.

Regards,
~Gergana

===================================
Gergana Slavova
Technical Consulting Engineer
Intel Cluster Tools
E-mail: gergana.s.slavova@intel.com

Gergana Slavova
Technical Consulting Engineer
Intel® Cluster Tools
E-mail: gergana.s.slavova_at_intel.com

Login to leave a comment.