app crashes when using call graph

app crashes when using call graph

ayalba's picture

Hi I am using V9.1 (same happened with 9.0) Eval.

I am trying to analyze my app but running Vtune with call graph is causing my app to crash after initial startup. the app gets launched (after being copied by vtune to app-backup.exe) but after a few secs, it crashes and no data is collected. needless to say, this does not happen when I run tha app separately.

I tried attaching to an already running app .. but that does not work ... the app does not crash but Vtune cannot attach to it with the following in the console :

Wed Dec 10 10:52:42 2008 Static instrumentation done

Wed Dec 10 10:52:43 2008 Error in module "c:\dev\superkal\bin\releasednb\app.exe" - Copying module failed.

Wed Dec 10 10:52:49 2008 Data collection halted...

I would appreciate it if anyone has any tips for me ...

thanks.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Tim Prince's picture

Is your application large? If moderately large, is the problem seen only when running on a 32-bit OS? If it is small enough that a 32-bit OS should not be a problem, with limited stack and heap, you could submit your case against VTune on premier.intel.com.

Call graph doesn't work with a running process; it relies on running a modified copy of the .exe, as you saw.

ayalba's picture
Quoting - tim18

Is your application large? If moderately large, is the problem seen only when running on a 32-bit OS? If it is small enough that a 32-bit OS should not be a problem, with limited stack and heap, you could submit your case against VTune on premier.intel.com.

Call graph doesn't work with a running process; it relies on running a modified copy of the .exe, as you saw.

what do you mean by large ? executable size = small (400KB) additional dll's = ~ 10MB.

The app is not large but uses a lot of mem ~1GB (its a 3d graphics app) . I am running on 32bit windows XP.

cheers.

Peter Wang (Intel)'s picture
Quoting - ayalba

Wed Dec 10 10:52:42 2008 Static instrumentation done

Wed Dec 10 10:52:43 2008 Error in module "c:devsuperkalbinreleasednbapp.exe" - Copying module failed.

Wed Dec 10 10:52:49 2008 Data collection halted...

It seems that Call graph static instrumentation was done (default call graph cache directory -C:Documents and Settings$userLocal SettingsTempCache(64)), it failed when call graph launched application. Must do 1) Copied instrumented app.exe from cache to c:devsuperkalbinreleasednb 2) Backup original app.exe 3) Lunch instrumented app.exe and collect data 4) Restore original app.exe

Based on error message, you failed to do step 1) - why you can't copy? app.exe was running by other user? You have no permission to replace with instrumented app.exe? You can no permission copy file from Cache?

Regards, Peter

Login to leave a comment.