AMT and Graphic BIOS setup screen

AMT and Graphic BIOS setup screen

Maria Camila Gomez-Silva's picture

Hello

Last week I was testing AMT with a Dell Latitude E6400 VPro labeled Laptop everything was working fine regarding AMT features... but something was wrong when using Remote reboot to Bios... I was getting something like "You are not allow to use SOL for this"

I noticed that the BIOS setup screen was a graphic screen from the OEM (Dell), the Management Engine accessed through CTRL+P was text based.

So I guess that SOL was not working to access BIOS because of this graphic interface, could this be the cause?

If yes.. why is an OEM setting a graphic BIOS setup to a VPro machine if this way the AMT functions for BIOS remote access using SOL are disabled?

Does anyone here have had this kind of problem?

Thanks

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Gael Hofemeier (Intel)'s picture

Quoting - maria.gomez

Hello

Last week I was testing AMT with a Dell Latitude E6400 VPro labeled Laptop everything was working fine regarding AMT features... but something was wrong when using Remote reboot to Bios... I was getting something like "You are not allow to use SOL for this"

I noticed that the BIOS setup screen was a graphic screen from the OEM (Dell), the Management Engine accessed through CTRL+P was text based.

So I guess that SOL was not working to access BIOS because of this graphic interface, could this be the cause?

If yes.. why is an OEM setting a graphic BIOS setup to a VPro machine if this way the AMT functions for BIOS remote access using SOL are disabled?

Does anyone here have had this kind of problem?

Thanks

Hi Maria, Your analysis to SOL not working sounds logical. We are going to need to escalate your question to find out if this is the case and if there is a work-around.

Gael

Follow me on Twitter: @GaelHof Facebook: https://www.facebook.com/GaelHof
Maria Camila Gomez-Silva's picture

Thanks Gael!

Gael Hofemeier (Intel)'s picture

Hi Maria - Did you make sure that SOL is enabled in the MEBX configurations? And also, some OEMs put an additional SOL/IDER enablement in the BIOS as well. Is this an AMT 2.6 system? We are being told that you should be able to do a SOL to BIOS if SOL is enabled both in the Firmware and in the MEBx configs. Is this your only Dell E6400? If not does it work on the others?

Gael

Follow me on Twitter: @GaelHof Facebook: https://www.facebook.com/GaelHof
Maria Camila Gomez-Silva's picture

Hi Gael!

We were invited to a Dell event where they had two Dell E6400 VPro Laptops (AMT 2.6), both had SOL enabled at the MEBx and no SOL option was present at the BIOS settings. We were not able to reboot to BIOS using SOL with none.

I was able to IDE-R with a DOS image using SOL Reboot to redirected CD, successfully.

Dell uses a nice grphic interface for BIOS with a tree menu and a graphic background using Dell's logo. I have never tested with any other Graphic BIOS interface just text based.

Hopefully I will have a couple of VPro Dell laptops next week so I will be able to test with some more time and I will let you know how does it go.

Thanks!

Maria

Gael Hofemeier (Intel)'s picture

Hi MariaCamila! Here is the scoop:

Systems shipped with A03 BIOS or earlier will have SoL/IDE-R disabled by default (in the firmware.) 
According to Dell, 1000-5000 systems were shipped in this state. 
BIOS A04 and above have this issue resolved. They recommend using the latest Dell BIOS A08.
Gael

Follow me on Twitter: @GaelHof Facebook: https://www.facebook.com/GaelHof
Maria Camila Gomez-Silva's picture

Thanks Gael i will check BIOS Version and make the update

MariaC

Gael Hofemeier (Intel)'s picture

Excellent!

Follow me on Twitter: @GaelHof Facebook: https://www.facebook.com/GaelHof

Login to leave a comment.