Array visualizer on 64 bit doesn't work

Array visualizer on 64 bit doesn't work

abhimodak's picture

Hi


I have no problems when using AV on the 32 bit operating system but it does not work on 64 bit.


On 32 bit (WinXP), the AV was installed in C:Program FilesIntel. I updated the include and lib paths using Tools --> Options --> Intel Fortran from Visual Studio.


On 64 bit (WinXP PRO), the AV is installed in C:Program Files (x86)Intel and I updated the include and lib paths as above. These paths point to the em64t subdirectory.


I cannot get the AV to work from the Visual Studioon the 64bit system. The view array remains greyed out.



Sincerely


Abhijit



8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Peter's picture
Abhimodak,

I know it has been long time since you posted your question. I am wondering if you got an answer ?

I have the same problem as yours. It worked fine with my 32 bit pc, but when i upgraded to 64 bit, visualizer doesnt work.

abhimodak's picture

Hi Peter

Sorry, I stopped checking this forum since the questions seemingly went cold...

However, as recently as yesterday, Steve Lionel has mentioned that he may try to to reproduce this problem. I mentioned this porblem on the mainstream Fortran compiler forum in context of another issue.

Hopefully there will an answer soon.

Abhi

johnreadey's picture
Quoting - abhimodak Hi Peter

Sorry, I stopped checking this forum since the questions seemingly went cold...

However, as recently as yesterday, Steve Lionel has mentioned that he may try to to reproduce this problem. I mentioned this porblem on the mainstream Fortran compiler forum in context of another issue.

Hopefully there will an answer soon.

Abhi

I'm running 64bit Vista and the Array Visualizer installed under Program Files. Also, if I run the Array Viewer and bring up the About Box, it shows: "BUILD 20060210 64 bit edition". I don't have Visual Fortran, so I can't say anything about the debug integration. If the 64-bit AV is installed correctly and "View Array" is not working, it's likely something that would need to be fixed in Visual Fortran. John
Steve Lionel (Intel)'s picture

I have reproduced the problem and will report it to the Visual Studio integration developers. I cannot promise that it will be fixed, however.

Steve
kholodov's picture

Please, help to get the Intel Array Visualizer and Viewer files: av_dev_em64t.zip and av_rt_em64t.zip
The site http://www.intel.com/cd/software/products/asmo-na/eng/compilers/226302.htm does not has them anymore.
My email can get that sizes.
If you have them please send me to kholodov@crec.mipt.ru

Thank you in advance.

Steve Lionel (Intel)'s picture

It seems all of those files disappeared. I will try to get them replaced.

Steve
Steve Lionel (Intel)'s picture

The files have been replaced. Sorry for the inconvenience.

Steve

Login to leave a comment.