KMP Affinity Issue

KMP Affinity Issue

Hi
We are using INTEL-MKL Pardiso solver in our programs and recently one of our clients reported that they are seeing the following message when the program runs on an computer with AMD microprocessor:

OMP: Warning #72: KMP_Affinity: affinity only supported for Intel processors. OMP: Warning #71: KMP_Affinity: affinity not supported, using "disabled"

and then, it aborts the program.

Recently we moved from MKL 10.3 Update 3  to MKL 10.3 Update 9 (Windows). The client also said that they did not see this happening with the previous version (that was using MKL 10.3.3.).

In the current version, we also provided the option of using "MKL_NUM_THREADS=1" or
"MKL_NUM_THREADS = All Physical Cores" (but we do not use OMP_NUM_THREADS or any other related parameters). It seems like "MKL_NUM_THREADS=1" is not helping much.

ANy help is appreciated.

Regards
Bulent

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,

As I know, Intel OpenMP library produses only warning on AMD CPUs and does not abort the program if KMP_AFFINITY env is used. It looks like your appication termination occurs because of other problem. Could you please create and share with us small tescase to reproduce this problem.

Thanks, -- Victor

Hello,

Have you ever externally set the KMP_Affinity environment? If so, it will report some warning on the none-intel system.

Also, I noticed a similar problem reported. The problem were expecting fix in the next major version of compiler, and the workaround is to "set KMP_AFFINITY=disabled"
http://redfort-software.intel.com/en-us/forums/showthread.php?t=105209

Thanks,
Chao

Login to leave a comment.