(0): internal error: 101006_4001

(0): internal error: 101006_4001

sergeyns's picture

Hello,

I'm getting "(0): internal error: 101006_4001" at linking step. I'm using IPO optimizations.

Anyone knows how to get past this ?

Thanks.

10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Jennifer J. (Intel)'s picture

You can add /Qnoipo to the linker to get around it. But then there's no IPO optimization.


Do you think you can send the source code to Premier Support ? And the latest 10.1 is 10.1.021.

sergeyns's picture

Is it ok if I send compiled object files ? Issue is reproduced on both ia32 and x64 compilers of 10.1.021 version.

Thanks

Jennifer J. (Intel)'s picture

Not really.


Could you isolate to which file that causes the problem? then you can send all others in .obj, only this one file in .cpp.


To isolate to file level:



  1. compile all files without ipo

  2. compile all files with ipo

  3. link 1/2 of obj from ipo folder, and 1/2 of obj from non-ipo folder to see if you get the error. use binary search methodto find the file.

Please see the ReleaseNotes on how to submit issues to Premier Support. It's not so complicated. And it's a secure site.

sergeyns's picture

I don't have Intel Premier Support account, can I do it without it ?

Jennifer J. (Intel)'s picture

Please visit here http://softwarecommunity.intel.com/support/to find the proper support you prefer.


To register, it's very easy. You can download an eval copy and you'll get an account.

sergeyns's picture

I must be blind...

The only steps how to register for support I found were:

6. click support account link and continue with the next step.

7. Provide your Name, Company Name and Country information.

Clicking on support account link opens this page http://www.intel.com/software/products/support

and that page doesn't look like something where I can enter my name, company name, and country information.

Thanks

Jennifer J. (Intel)'s picture

Sorry for those troubles.


If you registered at our Registration Center https://registrationcenter.intel.com/RegCenter/Register.aspx, you'll have an account at our Premier Support https://premier.intel.com/. It should be the same login name and pswd.


Hope it works this time. Thanks for trying!

sergeyns's picture

I have registered at that page, but still can't login to the second page, I always get

"We were unable to authenticate your access"

Thanks

Tim Prince's picture

The site supports only a limited number of browsers, including Microsoft and latest Firefox.

Login to leave a comment.