.NET Access Violations

.NET Access Violations

We have a site license for VTune and are using version 8 build 21288.

Whenever we try to launch a .NET application in VS2005 with the integrated VTune or when we launch the .NET app from the VTune GUI application it causes our .NET application to start throwing exceptions of the following sort:

System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
at System.ServiceModel.SynchronizedPool`1..ctor(Int32 maxCount)
at System.ServiceModel.Channels.BufferManager.PooledBufferManager..ctor(Int64 maxMemoryToPool, Int32 maxBufferSize)
at System.ServiceModel.Channels.TransportChannelListener.OnOpening()
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Dispatcher.ChannelDispatcher.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open()

It's a WCF app (.NET 3.0)

Basically the exception is only thrown when using VTune -- in this case the Call Graph Analyzer. This looks like there is some sort of priveledge problem with VTune and .NET protection mechanisms.

This appears to be the same problem as another recent post on this board: "Problem with VTune in Mixed Software Architecture".

Any suggested system settings fixes?

Thank you.

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

VTune requires Administrator rights, even for those functions which might have been possible without them.

We all have adminstrative rights. I don't think it's a priveledge issue as I wrote above.

I believe this is more likely an instrumentation bug with VTune.

After all, the app runs. But when certain modules execute an exception happens. But only when those modules execute.

Sorry, but version 8 did not support .NET* 3.0 (see System Requirement in the Release Notes). Please download the 9.0 eval (or upgrade if your support services are still in effect) and try it.

Regards, MrAnderson

All right, thanks.

My bad. Next time I'll RTFRN first.

Leave a Comment

Please sign in to add a comment. Not a member? Join today