Hyperthreading Woes

Hyperthreading Woes

darylseah's picture

I really want to try out hyperthreading, but when I enable it in BIOS, I find that the response from keyboard presses are slow. In fact, when I opened Task Manager to take a look, pressing a key shoots the CPU load up pretty high. And holding down the arrow keys shoots it all the way to 100% and freezes the whole system (as in screen freezes, mouse cursordoesn't move). All is fine if I don't use the keyboard at all (not acceptable of course).

I tried it on Windows 2000 Pro and Windows XP SP2. Both have the same problem. Evenflashed my motherboard BIOS to the latest version, but to no effect. I'm using the Gigabyte SINXP-1394 btw... And the filterkeys function in Windows is off.

I tried searching forums for people encountering the same problem. But I only found one case... with no solution.

Any idea what could be wrong?

I'm using the P4 3.0Ghz w/ HT.

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
xcheater2's picture


Could you specify did Intel make your keyboard and does it have HT branding logo on it? If it is not so you might have a non-compatible. keyboard.:smileyvery-happy:

darylseah's picture

Hi, it's not an Intel keyboard. It's a standard Logitech PS/2 qwerty keyboard. Err... You mean there are keyboards that actually aren't HT compatible? I thought HT should work independently of keyboard standards.

xcheater2's picture

Here I would recommend getting SUN computer and use it with keyboard, it is much more stable and faster. Dont worry about your keyboard it was a joke. It looks like you have something wrong with bios, check for an updated version or settings for the keyboard interruption time, make it smaller.

darylseah's picture

Hmm... not sure where I'm gonna get a SUN computer. And yeah, my BIOS is already as latest as it can get. Think Gigabyte discontinued updates for my mobo already. :( No keyboard interruption time in the BIOS either. Think I've been playing around with all the relevant settings too. At my wits end right now.

Login to leave a comment.