redhat 8.0 with VTune for Linux 1.x

redhat 8.0 with VTune for Linux 1.x

I am not able to get this installed.
When I launch the installer, I get error
libstdc++ version 2.96 must be installed - exiting.

I am able to use the Remote linux feature of VTune7,
but for some reason, I keep getting the following
message when executing callgraph of instrumented version:

"Cfg: Assertion failed '!output_image().is_in_imports(t.va())' at Bistro/fe/cfg.cxx:1520".

Anyone seen these issue before?

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,

I am sorry to inform you but RH8.0 is not supported by VTune Performance Analyzer 1.0/1.1 for Linux as well as by VTune Performance Analyzer 7.0 for Windows.

From Vtune analyzer 7.0 release notes:
For remote call graph profiling on Linux systems with supported 32-bit processors this version supports only Red Hat* versions 7.1, 7.2, 7.3 and Advanced Server 2.1 with corresponding GLIBC versions 2.2.2, 2.2.4 and 2.2.5. The applications to be profiled must be built with either GCC* version 2.96 or Intel compiler version 5.0, 6.0, or 7.0.

Vtune analyzer 1.0 for Linux supports the same platforms.
Vtune analyzer 1.1 for Linux supports these 4 platforms + SuSe 8.0, SuSe 8.1, SLES8.0.

Please always refer release notes for the list of supported OS-s / platforms:
- VTuneAnalyzer7.0Readme.htm - for Windows product (7.0, it is usually on the CD)
- VTLRELEASENOTES.htm - for Linux product (1.0/1.1, it is installed to the root vtune folder, /opt/intel/vtune by default).

Kind regards,
Konstantin Lupach

Login to leave a comment.