Serious error occured in file VTSvdp.cpp

Serious error occured in file VTSvdp.cpp

k.g.v.s.prasad's picture

Hello,
I am doing performance analysis of a java application.
While I am trying to goto source view I am getting 2 error messages one after the other.

Error1 ----> "Unexpected problem has occured. The Source View window will now be closed."

Error2 ----> "A serious error occured in the file D:vTune6.1AnalyzersrcsvdpVTSvdp.cpp at line 1467 ( unexpected problem has occured. the Source windows will now be closed. The failed HRESULT that produced this error is 0X80340004. Please contact technical support."

Please help me in this regard.
Regards,
Prasad.

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Daniel Bricker (Intel)'s picture

are you running call graph or sampling collection?
what Java do you use (MS, Sun, IBM)?
is it possible to get the test application you have problem with?

k.g.v.s.prasad's picture

Hello dbricker,
I am running sampling collection.
I am using Sun' JVM . I tried with JVM 1.3 and JVM 1.4 versions.
Attached zip file contains the java application being used and also information about usage of the application. It is a simple application.
Thanks and Regards,
Prasad.

Daniel Bricker (Intel)'s picture

hi,
thank you for your application!
i run it with vtune 7.0 but did not encountered any problems.
what vtune version do you use?
can you kindly File->"pack and go" your problematic project and attach it? please describe what was the exact sequence that led you to the problem. (for what function you tried to see with the source view?) please also be aware that w/o source files (you sent only binaries) the source view can show only disassembly. may be sources are needed to reproduce the problem?

As well you are welcome to submit a bug report to the support.

k.g.v.s.prasad's picture

Hello dbricker,
I am using VTune Performance Analyzer 6.1.
Attached zip file contain Java source files and a word document which discribes steps to be followed to reproduce the bug.

Could u please tell how to report bug to support...?
Please note that I am using Trail version.

I tried to attach project pack file but as its size is 175kb (after zipped), I failed to post it. Give me ur mail id. Mine is kprasad@vanenburg.com. I will send it through email.
regards,
Prasad.

Daniel Bricker (Intel)'s picture

hi Prasad!

Why you are not using the VTune 7.0 available from:
http://www.intel.com/software/products/vtune/

It includes some new features and improvements and bug fixes, of course :-). My be it solves your problems?

I do not know how to submit bug report for owners of the evaluation copies. Actually this is a very good question! May be you can post this question as a separate thread? I am sure Jeff (the Host) has a good answer for this.

I also sent you a mail using the address you gave.

-Daniel

k.g.v.s.prasad's picture

Hello daniel,
My project is working fine with VTune 7.0. No Serious errors are coming. Thanks for the suggestion.
Regards,
Prasad.

Daniel Bricker (Intel)'s picture

Prasad,

I am really happy it is!

-Daniel

moggy's picture

I'm having this exact same error using VTune 7 in Visual Studio .net 2002? I have no idea what's wrong with it!
If I try to use the source view window it just gives me this?

Anyone have any ideas?

thanks

Alex

Daniel Bricker (Intel)'s picture

Alex,

The best way is to submit this issue to Premier Intel support (you can do it with evaluation version also).
Hope support team can help.

Daniel

Konstantin Lupach (Intel)'s picture

Hi Alex,

You may go to and sumbit your bug. Please do not forget to attach your application if it is not very large. Note, you should be registered Premier Support user. If you are not a registered Premier Support user, contact your Field Representative for help obtaining access to this service.

You could also try to reinstall VTune.

Kind regards,
Konstantin Lupach

Konstantin Lupach (Intel)'s picture

I also wonder if this problem occurs on all applications.
Can you please try any simple app created by VS wizard and report if you can reproduce the problem.

If 'yes', please check in release notes if you use supported hardware, OS, etc.

Kind regards,
KL

Login to leave a comment.