Beta3 sample source sample_decode_s3d MFXVideoSession init failed

Beta3 sample source sample_decode_s3d MFXVideoSession init failed

admin's picture

command line and output is:

C:\\Program Files\\Intel\\Media SDK\\3.0.442.32245 Beta3\\samples\\_build\\Win32\\Debug>

sample_decode_s3d.exe mvc -i d:/test.mvc -o d:/out.yuv

Return on error: error code -3, c:\\program files\\intel\\media sdk\\3.0.442.32245 b

eta3\\samples\\sample_decode_s3d\\src\\pipeline_decode_s3d.cpp 435

Return on error: error code 1, c:\\program files\\intel\\media sdk\\3.0.442.32245 b

eta3\\samples\\sample_decode_s3d\\src\\sample_decode_s3d.cpp 170

But the binary sample_decode_s3d.exe Beta3 takes by itself running well, why?

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
admin's picture

One possible explanation for this behavior could be your system's search path.Is theMedia SDK 3 Beta 3 bin directoryincluded? Is it before older versions of Media SDK?

You may also want to check whether the library path matches the type of build you did on the sample (Win32/x64). If you run thebinary sampleincluded with the installation the matching Media SDK software DLL is in the same directory so thepath is not used in the search.

Please let us know if this does not get you started. We will be glad to investigate further.

Regards,

Jeff

admin's picture

Thank you Jeff,the reason iswrong lingking version of libmfxsw32.dll, when i copy my build to bin folder, everything is right

Login to leave a comment.