mixed language compiles

mixed language compiles

I had working mixed Fortran-C projects. I had to re-install both compilers due to system problems. Now the only way to compile the Fortran is to put it all in one file or I get LNK2001 errors during the compile (not the link). I carefully returned all my project settings to the previous values and I know these all worked before.

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

What seems to have happened is that Fortran lost the setting that says that the Fortran files should be compiled separately. We've seen this happen sometimes with projects created with one of the C++ wizards.

Select Project..Settings..Fortran In the Project Options box, type the switch /compile_only

That SHOULD fix it. If it doesn't, please send a ZIP file of the project to us at vf-support@compaq.com and we'll take a look.

Steve

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today