Debugging "Hello World"

Debugging "Hello World"

I am a first time VF user and am attempting to set a breakpoint and single step through the console "Hello World" app, my first out-of-the-box Fortran program. The problem is that the program completes when run without stopping at the breakpoint. Some possibly pesky messages occur during build and load.

If I start debugging by selecting "Step into" instead of "Go", execution stops at "while(GetMessage..." within WINAPI C-code.

I am undoubtedly suffering from Lori's "Multiple C-Library Syndrome" (April 2000 newsletter). I resolved the LNK4098 error by checking the /NODEFAULTLIB box.

Now, I receive the messages "Loaded C:WINNTsystem32
tdll.dll, no matching symbolic information found" for kernel32.dll, user32.dll, gdi32.dll, advapi32.dll, rpcrt4.dll, and olevt32.dll.

For Win32Debug, in the C/C++ tab of Project Settings, "Debug Singlethread" is selected.

In the Fortran tab of Project Settings, non-threaded and static and "Use Debug C libraries" are checked.

A pristine (new out-of-the-box) 500 MHz Celeron PC was loaded with WinNT 4.0 SP3, then MS Visual Studio 6.0, and then VF 6.1.

Thanks for any suggestions!

Phil
pfischer@wzrd.com

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Phil,

You won't suffer from MCLS with a Fortran-only program, and should not have checked the /NODEFAULTLIB box. Since you didn't say what "pesky" messages you got, I don't know how to advise you on that.

However - in the current version, you can't use Step Into to start a debug session, as it will step into the C RTL code. Instead, set a breakpoint on the first executable statement and click the GO button (or press F5.)

Steve

Steve Intel Developer Support

Login to leave a comment.