QT can't find Intel App SDK library files

QT can't find Intel App SDK library files

My Main.cpp ------------- #include #include #include #include "passrator.h" using namespace com::intel::adp; const ApplicationId myApplicationID(ADP_DEBUG_APPLICATIONID); int main(int argc, char *argv[]) { Application *myApplication = NULL; try { myApplication = new Application(myApplicationID); myApp->BeginEvent(); } catch (AdpErrorException) { // Your code to handle exceptions wcout << L"Caught exception in application: " << e.what() << endl; } QApplication a(argc, argv); passrator w; w.show(); return a.exec(); } My Pro file ----------------- #------------------------------------------------- # # Project created by QtCreator 2011-03-12T23:39:11 # #------------------------------------------------- QT += core gui TARGET = passrator TEMPLATE = app SOURCES += main.cpp\ passrator.cpp HEADERS += passrator.h \ C:/Program Files/Intel/IntelAppUpSDK/Cpp/include/adpcppf.h\ "C:/Program Files/Intel/IntelAppUpSDK/Cpp/include/ApplicationId.h" FORMS += passrator.ui OTHER_FILES += \ passrator.ico RC_FILE = passrator.rc RESOURCES += \ passrator.qrc LIBS = -L"c:\Program Files (x86)\Intel\IntelAppUpSDK\Cpp\lib" -ladpcored -ladpcppf -ladpcppfd -ladpcore #INCLUDEPATH += "C:\Program Files\Intel\IntelAppUpSDK\Cpp\lib\" ------------------------- ERROR Running build steps for project passrator... Configuration unchanged, skipping qmake step. Starting: "C:/Qt/2010.05/mingw/bin/mingw32-make.exe" -w mingw32-make: Entering directory `D:/QT/passrator-build-desktop' C:/Qt/2010.05/mingw/bin/mingw32-make -f Makefile.Debug mingw32-make[1]: Entering directory `D:/QT/passrator-build-desktop' g++ -c -g -frtti -fexceptions -mthreads -Wall -DUNICODE -DQT_LARGEFILE_SUPPORT -DQT_DLL -DQT_GUI_LIB -DQT_CORE_LIB -DQT_THREAD_SUPPORT -DQT_NEEDS_QMAIN -I"c:\Qt\2010.05\qt\include\QtCore" -I"c:\Qt\2010.05\qt\include\QtGui" -I"c:\Qt\2010.05\qt\include" -I"c:\Qt\2010.05\qt\include\ActiveQt" -I"debug" -I"." -I"..\passrator" -I"." -I"c:\Qt\2010.05\qt\mkspecs\win32-g++" -o debug\main.o ..\passrator\main.cpp mingw32-make[1]: Leaving directory `D:/QT/passrator-build-desktop' mingw32-make: Leaving directory `D:/QT/passrator-build-desktop' In file included from C:\Program Files\Intel\IntelAppUpSDK\Cpp\include\/InitializationException.h:24, from C:\Program Files\Intel\IntelAppUpSDK\Cpp\include\/Application.h:27, from C:\Program Files\Intel\IntelAppUpSDK\Cpp\include\adpcppf.h:21, from ..\passrator\main.cpp:2: C:\Program Files\Intel\IntelAppUpSDK\Cpp\include\/AdpErrorException.h:24:26: error: AdpException.h: No such file or directory In file included from C:\Program Files\Intel\IntelAppUpSDK\Cpp\include\/DefaultCrashReport.h:23, from C:\Program Files\Intel\IntelAppUpSDK\Cpp\include\adpcppf.h:23, from ..\passrator\main.cpp:2: C:\Program Files\Intel\IntelAppUpSDK\Cpp\include\/CallStack.h:35:22: error: dbghelp.h: No such file or directory ..\passrator\main.cpp:3:27: error: ApplicationId.h: No such file or directory ..\passrator\main.cpp: In function 'int qMain(int, char**)': ..\passrator\main.cpp:16: error: 'myApp' was not declared in this scope ..\passrator\main.cpp:20: error: 'wcout' was not declared in this scope ..\passrator\main.cpp:21: error: 'e' was not declared in this scope mingw32-make[1]: *** [debug/main.o] Error 1 mingw32-make: *** [debug] Error 2 The process "C:/Qt/2010.05/mingw/bin/mingw32-make.exe" exited with code %2. Error while building project passrator (target: Desktop) When executing build step 'Make' ------------------------------------------- I am using QT. I application work fine with integrating Intel App SDK.
6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

By default IADP_SDK_DIR_MEEGO environment variable is not added to the QT project environment to link AppUpSDK folders with QT.
You need to add that to project settings in QT then it builds fine.

May be Qt is unable to get the sdk properly....I also tried but got some errors.
So I shifted to VS2008.
I added the Qt plugin to VS2008. Build the application there & added the Intel app up sdk easily. As we can add the SDk to VS using the plugin. IT is working fine there.

Yes I just did that!

Bapi,

Did switching to Visual Studio 2008 fix this for you?

Yes, It solved.

Yet I am find to compel my software in QT.

Leave a Comment

Please sign in to add a comment. Not a member? Join today