Error during installation process of MeeGo 1.2 SDK for Linux: missing file(s)

Error during installation process of MeeGo 1.2 SDK for Linux: missing file(s)

I am unable to install stable MeeGo 1.2 SDK from the AppUp page: http://appdeveloper.intel.com/en-us/meego-sdk-suite Download link is: http://sdk.meego.com/installer/Linux/meego-sdk-installer-online-20110519 After Downloading In started the installation process: ./meego-sdk-installer-online-20110519 --verbose During the installation process I always get the following error message: --- Error during installation process(com.meego.sdk.targets.simulator.skin): Execution failed (Unexpected exit code: 100): "/home/jukey/.config/meego.com/sdk/pm/pm install meego-sdk-qt-simulator-skin" --- In terminal I see this output: --- Statusinformationen werden eingelesen... Fertig E: Paket meego-sdk-qt-simulator-skin kann nicht gefunden werden SHOW FINISHED PAGE FINISHED ENTERING: Control script callback FinishedPageCallback does not exist. --- I'm Using Ubuntu 11.04. Could you fix this please? Thanks Uwe
11 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Uwe,

This is a known bug 16884

https://bugs.meego.com/show_bug.cgi?id=16884

Currently the only supported Linux platforms are:

OS: 32-bit versions of Fedora 12, Fedora 13, Ubuntu 9.10, Ubuntu 10.04 LTS, and Ubuntu 10.10

http://appdeveloper.intel.com/en-us/article/installing-meego-sdk-linux

According to the notes in bug 16884, Ubuntu 11.04 support will be coming in July.

Hope this helps and good luck.

Hi Uwe:

Hi JAVA DEV:

I like to offer you an alternative for your development. If you have a netbook, you can install MeeGo and develop on it directly.
If you do not have a netbook, I suggest using VirtualBox on your host machine and install a copy of MeeGo.
The instructions for putting MeeGo on VirtualBox is here:

http://wiki.meego.com/SDK/Tablet/VirtualBox

However, don't follow the link on this URL to download MeeGo image. For proper image, please use this one instead:

http://repo.meego.com/MeeGo/builds/stable/1.2.0.90/1.2.0.90.4.20110614.1/images/meego-tablet-ia32-qemu/

The wiki has instructions and you need to do some conversion of this image. The conversion should take 5 to 10 minutes.

Either installation, whether on netbook or virtualbox, is only the first step. Let me know after you are done and I can guide you to next steps.
And of course, if you run into issues, just post them here.

Thanks

--Vincent

Thanks for your answer but I'm unable to install the SDk also using a MeeGo Netbook version:
$ cat /etc/meego-release
MeeGo release 1.2.0 (MeeGo)
BUILD: meego-netbook-ia32-1.2.0

An error dialog appears:
"Error during installation process(com.meego.sdk.pm):
Execution failed (Unexpected exit code: 127): "/home/jukey/.config/meego.com/sdk/pm/config_repo"

The verbose output says:
---
Environment..............................:LOGNAME=jukey;SYSFONT=latarcyrheb-sun16;SHLVL=4;AG_PROVIDERS=/usr/share/accounts/providers;DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-zQ1JmDqrp5,guid=96d475a7c041d25c0fafa60b00000063;PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/home/jukey/bin:/home/jukey/bin;USER=jukey;XDG_CACHE_HOME=/home/jukey/.cache;LANG=de_DE.UTF-8;WINDOWID=39845892;MAIL=/var/spool/mail/jukey;M_DECORATED=0;AG_SERVICES=/usr/share/accounts/services;_=./meego-sdk-installer-online-20110519;GNOME_DESKTOP_SESSION_ID=default;DISPLAY=:0.0;PWD=/home/jukey/Downloads;XDG_CONFIG_HOME=/home/jukey/.config;GIO_LAUNCHED_DESKTOP_FILE_PID=1054;XAUTHORITY=/home/jukey/.Xauthority;HISTCONTROL=ignoredups;HISTSIZE=1000;HOSTNAME=jukey-desktop;OOO_FORCE_DESKTOP=gnome;SSH_AGENT_PID=558;XDG_SESSION_COOKIE=693bda3e34b4ea6d907697e900000005-1308394289.67289-47083017;OLDPWD=/home/jukey;TERM=xterm;COLORTERM=gnome-terminal;SSH_AUTH_SOCK=/tmp/ssh-rlkcYJe557/agent.557;DBUS_STARTER_BUS_TYPE=session;G_BROKEN_FILENAMES=1;LESSOPEN=|/usr/bin/lesspipe.sh %s;LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:;LIBC_FATAL_STDERR_=1;GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/gnome-terminal.desktop;DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-zQ1JmDqrp5,guid=96d475a7c041d25c0fafa60b00000063;AG_SERVICE_TYPES=/usr/share/accounts/service-types;HOME=/home/jukey;SHELL=/bin/bash
void QProcessWrapper::setEnvironment(const QStringList&)
void QProcessWrapper::start(const QString&, const QStringList&, QFlags)
/home/jukey/.config/meego.com/sdk/pm/config_repo started, arguments:
operation 'Execute' with arguments: '/home/jukey/.config/meego.com/sdk/pm/config_repo; showStandardError' failed: Execution failed (Unexpected exit code: 127): "/home/jukey/.config/meego.com/sdk/pm/config_repo"
"create message box with identifier: 'installationErrorWithRetry'"
---

Any idea?

Thanks in advance, Uwe

Hi Uwe:

Let me know if you are open to an alternative option to development. I had the 1st part of that alternative above on this thread.
These errors are being worked on but the alternative option can you going without waiting any further.

thanks

--Vincent

HI Vincent,

you wrote:

I like to offer you an alternative for your development. If you have a netbook, you can install MeeGo and develop on it directly.

I have an Netbook only and I thougt the way to do this is to install MeeGo SDK on it. If this is not the right please let me know how to go on.

Hi Uwe: Sorry for the late reply.

If you have a netbook with MeeGo running, you do not need to have MeeGo SDK.

You have two options:

1) Try to install Qt SDK which gives you nice GUI based development toolchains like Qt Creator.

2) Use commandline compilers like gcc and editors like vi or emacs.

Let me know what you prefer and I can post relevant steps.

--Vincent

And where can I find Qt SDK for MeeGo? The sources I found are only for the standard Linux distributions like Ubuntu etc.

Hi David:

Qt dev libraries can be found locally on MeeGo via "zypper search".

Or you can try to download from http://qt.nokia.com

They have a generic Linux version and also a Linux installer.

Let me know if you have questions.

thanks

-Vincent

Zypper search worked. The package was downloaded and installed sucessfully. But if I want to build something with Qt-Creator, it says it istn't correctly installed and I should execute "make install".

Hi David: When you said "it says it isn't correctly installed", is the message referring to Qt Creator not installed properly? And where are you seeing this message?

Leave a Comment

Please sign in to add a comment. Not a member? Join today