Error installing AppUp Client

Error installing AppUp Client

Hi. I've been setting up a Meego system for testing but so far, I've been unable to successfully install the AppUp client. I downloaded the Meego version for netbooks. However when I enter rpm -i, I get the following error message: error: Failed dependencies: meego-release >= 1.1 is needed by is needed by is needed by I believe I am running the latest version of Meego as I have just updated it and the update centre says everything is up to date. Does anyone know what I can do to fix this and install AppUp correctly? Thanks in advance for your help.
9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

These two links may get you on the correct path:

Thanks for the hints but I've not quite got it yet. Firstly, it is still saying that the version of Meego I'm using is not correct with the line:

meego-release >= 1.1 is needed by

I've also been reading that updating the version of meego is not supported and so you need to do a reinstall. Is that really correct? Is there any way I can check what version I'm using? I thought I was on 1.2 but that would contradict the message above.

Also about the rpmfind site. Each time I download an rpm dependency and try to install it, it gives me another load of missing dependences. I did this a few times but when it asked for Python and I tried that, it gave me about 15 other missing packages. I'm not that familiar with linux so before I spend a couple of hours going through all these packages manually installing them, could you tell me if this is actually what I'm meant to be doing and whether it is likely to fix the problem?

Thanks again for your help.

EDIT: Oh and one other slightly off topic thing... Why am I able to vote on my own rating (out of 5 stars) at the top of this thread and not on yours? Surely we should be rating one another, not ourselves? Sorry; I'm still learning the ropes here :)

Hi Lucas:

From the same terminal where you tried to install client, can you issue this command:

cat /etc/meego-release

and post your output here?



Ah so that's how you find your version. The output is, of course:

Meego release 1.0 (Meego)
BUILD: meego-1.0-netbook-20100524.1

Strange I could have sworn I had 1.2 but I should really have know the computer was right :p. So is it possible to upgrade to 1.2 from where I am or do I have to reinstall? It's just that the update centre says everything is up to date...

Hi Lucas:

You can get a newer MeeGo netbook image from



Thanks for the link. I fear the laptop I'm using isn't all that compatible as I found Chromium constantly gave me "Aw snap!" so I couldn't use it and the netbook version of AppUp couldn't be installed as the window renders incorrectly so that it is impossible to accept the EULA (button or checkbox is hidden) but I've managed to get the AppUp client for tablet computers running OK so thanks for all the help! Hopefully some future build of the netbook client will work too. Anyhow I couldn't have got it all set up without all your advice so thanks again.

Hi Lucas:

If your problem is strickly confined to a browser glitches, you are welcome to give Opera a try. It is available here:

Try the "Meego generic" version.

It may be another viable internet browsing option for you.



Thanks, Opera is the browser I'm using now, Google Chrome having failed to install. I was just having fun getting it at all without a functioning web browser or any usb ports! Anyhow the system is pretty much up and running now, give or take a few glitches, and the tablet version of the AppUp client is usable until a fix is released for the netbook version. Thanks again for all your help. I look forwards to developing for the platform!

Leave a Comment

Please sign in to add a comment. Not a member? Join today