New Forum design - hard to read text of topic

New Forum design - hard to read text of topic

Quba's picture

I have problems to read topics in the new forum design. I am using Firefox 15.0 browser.

All forum looks like in the fog. Font of the text of topic is not black but gray so it is difficult to read to me.

Is there any possibility to change forum appearance (in user preferences)?

50 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Tim Prince's picture

I had no problem with the new fonts, having made the FF font selections larger prior to the FF15 upgrade. For ff15/Windows, options>options>content>default font. I do have to tinker with the screen resolution when I switch my Windows laptop to a monitor.

Steve Lionel (Intel)'s picture

There is no user customization of this, but I will pass on your complaint (which I agree with).

Steve
Sergey Kostrov's picture

Quote:

Quba wrote:

I have problems to read topics in the new forum design. I am using Firefox 15.0 browser.

All forum looks like in the fog. Font of the text of topic is not black but gray so it is difficult to read to me.

Is there any possibility to change forum appearance (in user preferences)?

I absolutely agree that a gray-on-white combination is not the best. It is very difficult to read. Steve, There are lots of issues with the new design and I think it has to be taken seriously. The Internet-Search-Integrity of thousand of posts on Intel Forums is destroyed. Some old links cached by Google don't work any longer! Many Forum posts are simply disappeared! It is significantly slower now! Best regards, Sergey
David White's picture

Further to the gray-on-white issues - the quoted text, gray-on-gray is also a problem.

thanks,

David

Steve Lionel (Intel)'s picture

My tests, done before this forum went live, showed that old links continued to work, redirecting to the new URL. I will check this again and file a report if that doesn't happen.

Steve
Les Neilson's picture

Steve,
Another observation.
The old system numbered the replies and a reply indicated which number it was a reply to. I don't know about others but I found it useful.

P.S. I seem to have lost my photo taken from the days when I was young and handsome :-(
Les

iliyapolak's picture

I cannot even submit any answers,because of anti-spam filter is blocking my posts.

Steve Lionel (Intel)'s picture

iliyapolak, I can see this reply. Are you still seeing a problem here?

Steve
Paul Curtis's picture

ditto other comments:
1) grey text very hard to read, pls change to black
2) does not preserve login (Firefox, cookies enabled)
3) supported upload file types do not include .for and .f90 (!!!)

David DiLaura's picture

Yes, and what happened to paragraph marks? Line feeds and paragraphs are typed, but they don't appear to be used when the text appears on the Forum. If you look at all the postings on the forum, there are no paragraph formatting (that is, empty lines)
Yes, and what happened to the spell checker? Communicating is hard enough without a geek having to worry about his grammatical pants being pulled down.
Yes, and what happened to the hit/read count that accompanied each topic? That was interesting information.

Manishg440's picture

I had no problem with new font and new,according to me now it's looks batter then last.

Steve Lionel (Intel)'s picture

The font color has been fixed (except in the box where you type in comments, I see. The paragraph problem has also been reported.

Steve
Sergey Kostrov's picture

Hi Steve,

Did you have a chance to discuss / escalate performance issues with the new portal? We shortly discussed it already. Thanks in advance.

Best regards,
Sergey

PS: I'll provide more technical details regarding performance issues later...

Steve Lionel (Intel)'s picture

Sergey, I've been traveling continuously since we chatted and have not yet had the chance to discuss your comments with the IDZ team. That said, I am not seeing performance issues - at least not any worse than the old forums - so please do provide some details if you can.

Steve
Sergey Kostrov's picture

Quote:

sblionel wrote:

Sergey, I've been traveling continuously since we chatted and have not yet had the chance to discuss your comments with the IDZ team. That said, I am not seeing performance issues - at least not any worse than the old forums - so please do provide some details if you can.

... Here are steps to reproduce: ... - Launch Internet Explorer - Select in menu: Tools -> Internet Options -> Press 'Select' button in 'Change how webpages are displayed in tabs.' -> Disable a checkbox 'EnableTabbed Browsing (...)' - Open Windows Task Manager and select a 'Processes' property page ( click on a 1st column to order by name all running applications ) - Select a forum on the IDZ and try to open as many as possible posts, for example 20 or 30, by using right click and then 'Open in New Window'. So, every post should be displayed in its own IE (!) - When all Internet Explorers loaded content CPU(s) utilization ( CPU column ) is NOT zero and something is continuously executed (!) and it affects the whole system ... I think it is related to a new editor control since there wasn't any network related transfers ( could be easily verified on 'Networking' property page of Windows Task Manager ) when I tested it. Also, a cursor in the editor control is not blinking like in a Windows Notebook, for example, and it is displayed almost continuously. ... Best regards, Sergey
Steve Lionel (Intel)'s picture

That seems to be more a test of starting IE than the forum. Perhaps there is more JavaScript being loaded, but once loaded in a browser session it should be cached. I find that actual forum use (reading, posting) is usually faster now than in the old forums, where it could often take a minute or more for a page to update.

Steve
Sergey Kostrov's picture

>>...That seems to be more a test of starting IE than the forum.
___ No. As I already told something goes wrong with a new Edit control ( it could be also related to something else... ).

>>...Perhaps there is more JavaScript being loaded, but once loaded in a browser session it should be cached.
___ It is not related to caching. It looks like there is a "crazy loop" in some Jscript and it affects overall performance of the system when many IEs loaded.

iliyapolak's picture

>>iliyapolak, I can see this reply. Are you still seeing a problem here?>>

Steve Lionel!
Sorry for my late answer to your question.Now everything related to sending new posts seems to be ok.
But there are still some issues for example how can i make a privete post.

Sergey Kostrov's picture

>>...how can i make a privete post...
>>...

Hi Iliya,
It looks like it is not allowed any longer and a 'Send Author A Message' functionality has to be used instead.
Best regards,
Sergey

iliyapolak's picture

>>..Hi Iliya,
It looks like it is not allowed any longer and a 'Send Author A Message' functionality has to be used instead.>>

Thank you Sergey.

John Campbell's picture

There have been a lot of comments about changed functionality of the new forum, but very little response on why the changes were made or if some "problems" identified will be repaired.
Will the "LAST POST/NEXT POST"navigation buttons return ?
Loss of formatting using spaces is also annoying.
I can't identify the significant advance this new forum provides.
It appears we should just use what we have.
John

rase's picture

I agree with John that it is hard to recognize the advantages of the new forum. But going back to the old forum would probably cause a lot of effort with many chances to screw it up again. Let's stick to the new forum, with the improvements suggested here.

Sergey Kostrov's picture

>>...I agree with John that it is hard to recognize the advantages of the new forum.
.
I also agree with the point and I don't see any responses from Intel that we're working very hard to solve all detected issues and problems. Here are a couple of them:
.
- Performance problems ( some Jscript is loading CPU(s) for 100% )
- Formatting functionality of the new editor
- How could we submit source codes? Attaching files is not convinient and they could be lost
- Why does the new editor delete spaces?
- Removed post numbers and how could I refer to some post? In the old system all posts were numbered and it was very useful!
.
>> But going back to the old forum would probably cause a lot of effort with many chances to screw it up again.
.
That is simply not possible. A main reason for an upgrade was '...It was too difficult to maintain the old system...' This is an official statement from an Intel manager.
.
>>...Let's stick to the new forum
.
This is exactly what Intel wants to achieve.
.
Best regards,
Sergey

John Campbell's picture

I was not suggesting that we go back to the old forum. I was noting the lack of response from Intel to identified problems with the functionality of the new forum.
I am surprised that the forum was changed to a new version which has a number of significant flaws. Will there be any recognition of these problems and an indication if some of them will be addressed.
-The last/next topic buttons have been lost.
-The post numbers have been removed.
-The comment box has bugs with the (intuitive) commands. (Why doen't up arrow work !!)
-I can't find speel check or text boxes.
-Any space formatting of posts is removed.
Maybe I should be more fluent in html, but my speciality is Fortran. (possibly says something of the developer of this new forum, rather than a focus on the user)
.
As a +ve:
I like the new attach. It's much simpler, although given that .for and .f90 are not supported, there was clearly a lack of consideration of who uses this forum. (why has this happened!!)
.
Most of us have experienced providing upgrades to users. As an upgrade, I'd expect the client feedback survey for this upgrade would not give a high score. I know a better performance is expected from my upgrade implementations.
This upgrade is a puzzle to me. Few identifiable improvements and some significant failures or omissions. I would have expected to experience better from a premium solutions provider like Intel.
My apologies for going on, but my experience of this upgrade has certainly dented my view of Intel Software's reputation. I am truely surprised.
.
It would be good to get feedback indicating if some improvements are possible.
.
John

Steve Lionel (Intel)'s picture

All of these issues have been reported to the Intel Developer Zone team and will be addressed.

Steve
Sergey Kostrov's picture

>>...All of these issues have been reported to the Intel Developer Zone team and will be addresses.
.
Is it difficult to change the color of a text in the new editor? No, however it is not done in 4 weeks!
.
Dear IDZ managers and developers, Do you understand that some people have vision problems? I can't read clearly and I need ro move my head as closer as possible to my display.

Sergey Kostrov's picture

Continued...
.
Dear IDZ managers and developers,
.
Some companies, for example Digital Photography Review, are asking for users' feedback before a major update is done to a community forum(s). Please follow a link and it would be nice if Intel thinks about a community of developers and follows the same respectful way:
.
http://www.dpreview.com/news/2012/09/27/Forums-Redesign-2012

.
....
Major update to dpreview forums coming soon: tell us what you think
.
In an ongoing effort to improve the performance and user experience on dpreview, we've rewritten and redesigned the forums, and will be launching the new version in a few days. From a look-and-feel standpoint, we made an effort to stay faithful to the core of the old design (no point throwing out the bits that work well) and from a functional standpoint, we focused on adding, rather than removing features....
.
Best regards,
Sergey

Sergey Kostrov's picture

I see that some changes are done regarding a secure internet access ( http instead of https ):
.
Before I had to use https://secure-software.intel.com/user/[nnnnnn]/track
.
Now I could use https://software.intel.com/user/[nnnnnn]/track
.
Any comments or recommendations?

Sergey Kostrov's picture

I see that some changes are done regarding a secure internet access ( http instead of https ):
.
Before I had to use https://secure-software.intel.com/user/[nnnnnn]/track
.
Now I could use http://software.intel.com/user/[nnnnnn]/track
.
Any comments or recommendations?

Steve Lionel (Intel)'s picture

Either one should work - but in general we suggest you use software.intel.com if you are saving URLs. https is used to protect user content.

Steve
Sergey Kostrov's picture

>>...Either one should work - but in general we suggest you use software.intel.com
.
Thank you, Steve. I hoped that it would improve performance of IDZ website but unfortunately I didn't see improvements.
.
Best regards,
Sergey

Sergey Kostrov's picture

Steve, there is a problem with dates in a 'Last Updated' column on a User's Contributions web-page. Dates are not right and I'll provide an example later.

Sergey Kostrov's picture

>>...there is a problem with dates in a 'Last Updated' column on a User's Contributions web-page...
.
Here are simple steps to see the problem:
.
- follow a link: http://software.intel.com/user/353909/track
- at the bottom of the web-page select a web-page #5
- select a Forum topic 'KMP_Affinity' ( it shows Last Updated 1 month 1 week ago )
- a last post was done by a user 'Repeat Offender' on Sun, 05/20/2012, that is more than 1 month 1 week ago

Annalee (Intel)'s picture

For older threads, the last updated date is showing when the thread was migrated to the new forums

Annalee

Sergey Kostrov's picture

>>...For older threads, the last updated date is showing when the thread was migrated to the new forums
.
That explains the reason. Thanks.

Sergey Kostrov's picture

>>Dear IDZ managers and developers,
>>
>>Some companies, for example Digital Photography Review, are asking for users' feedback before a major update is done to
>>a community forum(s)...
.
I really like how that upgrade was done and please take a look at another update:
.
...Just deployed: New dpreview.com forums system
.
...http://www.dpreview.com/news/2012/10/03/New-dpreview-forum-system-launched
.
Please consider the same approach in the future.

Sergey Kostrov's picture

Hi everybody,
.
This is simply to report that today I had a strange error message on IDZ:
.
...Error message: The spam filter installed on this site is currently unavailable...
.
Any comments? It was discussed some time ago that it would be nice to have an absolutely generic forum dedicated to problems, errors and issues with IDZ website. Any progress on this?

Sergey Kostrov's picture

>>...Embed content by wrapping a supported URL in … .
.
Could I embed an image using these directives? Is that a correct form:
.
SomeLocaDrive:\SomeFolder1\SomeFolder2\SomeImage.jpg

Annalee (Intel)'s picture

The url should not be a local drive, it should be somewhere universally acessable. The embed keyword does not appear to be working though.

http://software.intel.com/sites/default/files/styles/large/public/compos...

edit: Embedding videos is working

Sergey Kostrov's picture

>>...The url should not be a local drive, it should be somewhere universally acessable. The embed keyword does not appear to be
>>working though.
..
Thanks. Is there a timeline on when all these problems / issues could be fixed?

Annalee (Intel)'s picture

The IDZ developers are working on these and issues that have been reported. Is there a particlar issue you would like a timeline for?

Thanks,
Annalee

Sergey Kostrov's picture

>>...Is there a particlar issue you would like a timeline for?
.
Yes, I have and I will create a short list with as better as possible descriptions. Thanks.
.
Best regards,
Sergey

Sergey Kostrov's picture

>>...Is there a particlar issue you would like a timeline for?
.
Mark, I don't want to define a deadline because this is not my responsibility. So, there are a couple of issues I'd like to mention:
.
1. It is hard to read texts on the IDZ because black colors are no longer used. In the new editor an RGB value for a text is ( 128, 128, 128 ). It would be nice to make it darker and an RGB value ( 96, 96, 96 ) or ( 64, 64, 64 ) will make a difference. I see that this is related to new web-design standards / policies adopted in Intel Corporation. However, think about IDZ users who are helping Intel Corporation for free to help in resolving different issues and problems with Intel software. Please respect our time! Because of different issues with the new IDZ web-site I was forced to reduce my activity and now I could hardly monitor about three forums. On the old ISN web-site I was able to monitor almost all forums.
.
2. A performance problem with the IDZ. It was already described and here are steps to reproduce:
.
- Launch Internet Explorer
- Select in menu: Tools -> Internet Options -> Press 'Select' button in 'Change how webpages are displayed in tabs.' -> Disable a checkbox 'EnableTabbed Browsing (...)'
- Restart Internet Explorer
- Open Windows Task Manager and select a 'Processes' property page ( click on a 1st column to order by name all running applications )
- Select a forum on the IDZ and try to open as many as possible posts, for example 20 or 30, by using right click and then 'Open in New Window' ( ! ). So, every post should be displayed in its own IE (!)
- When all Internet Explorers loaded content CPU(s) utilization ( CPU column ) is NOT zero and something is continuously executed (!) and it affects the whole system.
.
I think it is related to a new editor control since there wasn't any network related transfers ( could be easily verified on 'Networking' property page of Windows Task Manager ) when I tested it. Also, a cursor in the editor control is not blinking like in a Windows Notebook, for example, and it is displayed almost continuously.
.
3. Formatting of our comments. Can you see that I'm forced to use a dot '.' in order to separate different blocks of text in my comments and source codes. Here is a small example:


#include 
void main( void )

{

     printf( "Hello, IDZ!n" );

}


.
4. Can you see that a font was changed?
.
5. [Edited] Can you see that it was NOT restored? However in some cases it is restored.
.
6. Posts numbering was a very useful feature of the old ISN system. How could we refer to some post?
.
7. 'Preview' button was deleted.
.
8. Access to 'Files' of the old ISN system. I had lots of docs, zip files, screenshots, etc, and now I don't have a direct access to these files.
.
9. When I press on a link '1 new' post the IDZ system doesn't display that last post.

Les Neilson's picture

(1) Reinstate post numbering. (Which post am I replying to now?)
(2) Reinstate Previous / Next buttons when reading a post thread
(3) Text colour darker
(4) I haven't tried to attach files for a while but hopefully Fortran files will be invited to join the party. And maybe C/C++/C# if we have to ;-)

Would be nice to have :
For a very short while there was a time when unread topics were in a different colour to the rest. That was very nice. I sometimes miss a new post which has 0 views as I quickly skim looking for "n new"
If I remember correctly the "unread" colour was magenta rather than cyan.
I miss seeing my handsome features next to my name, and editing my profile does not give me any option to reinstate / re-send my photo. Not that I am vain or anything but ...

Sergey Kostrov's picture

This is a feature request and it would be nice to have a new type of icon. When a problem is solved a post in a forum could be marked as 'Solved' and the icon should be changed. In that case IDZ users will be able to see that solution was found, etc.

Sergey Kostrov's picture

>>...(4) I haven't tried to attach files for a while but hopefully Fortran files will be invited to join the party...
.
I tried it with txt files and it worked well. However, Jim had an opposite problem when he tried to delete a file with extension 'docx' after it was attached to a post.

Sergey Kostrov's picture

>>3. Formatting of our comments. Can you see that I'm forced to use a dot '.' in order to separate different blocks of text...

This is a test 1: [EDITED] FIXED. Thank you!

aaa
bbb
ccc

111
222
333

This is a test 2: [EDITED] Not FIXED yet: extra lines are added and "include arrow-left io.h arrow-right" is Not displayed properly.


#include 
int main( void )

{

   return 0;

}

Sergey Kostrov's picture

@Annalee:

Regarding performance issues / problems with the IDZ website: I've created a new post that provides some technical details and please take a look if interested:

Forum: Intel C++ compiler
Forum topic: A performance problem with the IDZ web-site
Web-link: http://software.intel.com/en-us/forums/topic/328990

Best regards,
Sergey

Sergey Kostrov's picture

>>...Is there any possibility to change forum appearance (in user preferences)?

I tried to change the text color ( from light grey to black ) in IE's 'Internet Options' and it didn't work.

Login to leave a comment.