Installation Problem

Installation Problem

Ted Rosenbaum's picture

Hi,

I apologize if this is not the correct forum for this.

I am trying to install fortran composerxe on gentoo. I run the installation and it simply says "failed" next to each component of the composerxe software.  Is there any way to get a more detailed error message as to what the problem is?

Thanks.

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Tim Prince's picture

There is a separate forum about installation, but you could ask specific questions here.
Please check the prerequisites described in the installation notes documentation. Among the more common problems are that you didn't install the g++ development system (no more recent than g++ 4.6 for composer 2011, 4.7 OK for composer 2013) or that you didn't acquire permissions on the directories you need for installation (possibly including /tmp).
You can install only the ia32 compiler on a 32-bit (ix86) linux.
For x86_64 linux, the basic g++ development system would support installation of the intel64 compiler. You would have to add a 32-bit g++ in order to install the ia32 compiler.
If the documentation link at the top of this forum doesn't lead you to the documents about installation on linux versions which aren't fully supported, that's a forum bug. I'll look at that now.
As you should be able to see, we need more information to help:
linux version (e.g. from uname -a)
g++ version (g++ -version)
exact error messages from ifort installer, and exact version of installer

Tim Prince's picture

As far as I can see, there is no link to the useful documentation which was posted at the top of the forum prior to the recent changeover. I'm filing a bug ticket.

Steve Lionel (Intel)'s picture

Actually, the separate forum is for download, licensing and registration issues only. The "useful information" list will return soon.

Gentoo isn't a supported distribution. I suggest you start with http://software.intel.com/en-us/articles/intel-compilers-linux-installat...

Steve
Ted Rosenbaum's picture

Hi,
Thanks for the responses. Reinstalling some packages in Gentoo allowed me to install without incident.

Login to leave a comment.