How to disable auto-vectorization?

How to disable auto-vectorization?

How do you disable auto-vectorization? Meaning that even when I declare typen (float4, int4, etc) variables, the compiler won't do any implicit vectorazation for the code, since what I've found in this thread:
http://software.intel.com/en-us/forums/topic/281812

seems like declaring __attribute__((vec_type_hint(float))) does not do anything such..

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Best Reply

Do you want to disable just auto-vectorization or all optimizations? You can use -cl-opt-disable to disable all optimizations (incl. auto-vec). From the SDK documentation, vec_type_hint doesnt disable auto-vectorization, instead it tells the vectorization module to apply transformation to a particular type.

Thanks,
Raghu

Leave a Comment

Please sign in to add a comment. Not a member? Join today