Intel 945GM with NonEDIDMode no effect

Intel 945GM with NonEDIDMode no effect

Hi Experts,

I know this has been discussed since 2006 & believe me, i've read, read, read & tried, tried, tried. My Dell ST2320L monitor suddenly decided to stop giving out EDID data after my WinXP crashed. But the CI channel still works as I can still control the brightness & contrast. Just the DDC died. So I tried http://www.intel.com/support/graphics/sb/CS-030332.htm

Following guidelines to find the correct DTDs for ST2320L, I googled up the modeline / raw data & used the DTD Calculator to get the DTD for ST2320L & modified kit13056.inf to just 1 item.

[NonEDIDMode_AddSwSettings]
HKR,, TotalDTDCount, %REG_DWORD%, 1 ; This shows number of DTDs to be used. ; 0-->Disable the feature.
;Following keys have 20 bytes (18 byte DTD + 2 Byte flags).
HKR,, DTD_1, %REG_BINARY%, 02,3A,80,18,71,38,2D,40,58,2C,45,00,FD,1E,11,00,00,1E,37,01 ;1920x1080@60...Progressive DELL ST2320L

[NonEDIDMode_DelSwSettings]
HKR,, TotalDTDCount
HKR,, DTD_1

NO EFFECT - After restart, once monitor is plugged in, the basic 800x600 & 1024x768 are the only resolutions available. If I were to change it from the Windows Display Property to 1920x1080 & extend desktop, then the resolution sent was still 1024x768 but you can pan the entire 1920x1080, which defeats the purpose of having a 23 inch screen.

I even tried reducing the horizontal resolution by 8 pixels using DTD Calculator, knowing full well that before the DDC died, I did get 1920x1080 so certainly this resolution is not barred, but I tried anyway so my new DTD was

HKR,, DTD_1, %REG_BINARY%, 02,3A,78,20,71,38,2D,40,60,2C,45,00,FD,1E,11,00,00,1E,37,01 ;1912x1080@60...Progressive DELL ST2320L

Still FAILED - NO EFFECT after reboot.

My poor old Inspiron 6400 is still working but a new monitor isn't. Below is the cut & paste from Intel's graphics properties Information screen. This is after using the latest INF file. The original driver was 945GM rather than just 945.

Accelerator in Use: Mobile Intel(R) 945 Express Chipset Family
Video BIOS: 1264
Current Graphics Mode: 1280 by 800 True Color (61 Hz)

I even tried updated the original driver's INF file to insert the NonEDIDMode_AddSwSettings but still has no effect.

Where did I go wrong? Please HELP!

Many thanks in advance.

1 post / 0 new
For more complete information about compiler optimizations, see our Optimization Notice.