ICC 2013 and vtune install problem

ICC 2013 and vtune install problem

Xuebin Yang (Intel)'s picture

When I installed icc with l_ccompxe_intel64_2013.1.117.tgz, it shows that my OS (Fedora 14 or 16) are unsupported OS. By skipping those prerequest, the compiler are installed on machine finally. Then I typed icc under /opt/intel/bin, but it said it cannot find libintelremotemon.so. What should I do?

And when installing vtune with vtune_amplifier_xe_2013_update2.tar.gz, it halts as below:

Step no: 5 of 6 | Installation
--------------------------------------------------------------------------------
Each component will be installed individually. If you cancel the installation,
components that have been completely installed will remain on your system. This
installation may take several minutes, depending on your system and the options
you selected.
--------------------------------------------------------------------------------
Installing Amplifier XE Command line interface component... done
--------------------------------------------------------------------------------
Installing Amplifier XE Sampling driver kit component...
  WARNING: Failed to build driver.
Suggestion: after the installation completes, see
'/opt/intel/vtune_amplifier_xe_2013/sepdk/src/README.txt' for information on how
to build and load the driver into the kernel.
--------------------------------------------------------------------------------
Installing Amplifier XE Power driver kit component...

 

And the README.txt' file is empty.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Tim Prince's picture

Your first problem appears to be due to not setting LD_LIBRARY_PATH. The instructions about sourceing the compilervars script would take care of that.
As the VTune driver has to be built locally when your kernel doesn't match exactly one of the pre-built drivers, the message and requirement to run the build-driver script in sepdk/src/ is expected. If you need turther assistance, please search the companion forum about VTune and post any follow-up questions there.

Xuebin Yang (Intel)'s picture

1. How to set LD_LIBRARY_PATH? What I means is its content, I have installed ICC under /opt/intel
2 How can I uninstall ICC 2013? I tried to reinstall it but it lets me to uninstall first. But there is no uninstall.sh under /opt/intel. Are there any problem of my installation? Thanks

Tim Prince's picture

The compiler installation includes the scripts compilervars.sh (bash compatible) and compilervars.csh (tcsh compatible) which are to be sourced to set the PATH and LD_LIBRARY_PATH. The instructions about this echo to the screen when you install.
The usual reason for not seeing uninstall scripts in the compiler installation is that you have deleted them yourself. In that case, you must find the rpmdb entries, e.g.
rpm -qa grep intel
and remove them
sudo rpm -e .......
in order to be permitted to re-install.

Login to leave a comment.