phonegap.js support

phonegap.js support

When I use phonegap build directly, I can include a ref to phonegap.js and build automatically supplies it during the compile. However, when I run the Emulator via the Intel dev tools, it get a 404 for this file.

What's the suggested approach here? If I include the actual file(s) that build provides, I will (I suspect) cause problems when I do builds using phonegap build directly.

suggestions?

mamund
4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The Device Emulator supports PhoneGap v2.0 only. So download Cordorva.js (v2.0) and put it on the top level as "index.html".

Jennifer

Jennifer:

Thanks for the response. To make sure I understand your reply:
- Devs MUST include a cordova.js file in your C9 project
- Currently the ONLY version of cordova.js that will work for the emulator is 2.0

A follow-up Q:
If i *do* include cordova.js (v 2.0) in my project, MUST I remove it before submitting the project to build.phonegap.com?

Thanks.

mamund

if your app does not use PhoneGap APIs, you do not need to include cordova.js.
also, cordova.js v2.x should work, not only v2.0.

For uploading to PhoneGap Build, it is ok to keep cordova.js. It will be replaced with the version specified in the config.xml.

Jennifer

Leave a Comment

Please sign in to add a comment. Not a member? Join today