Installation problèms

Installation problèms

Good afternoon,

I'm trying to intal the intel C++ compiler 11.1.067 pro on a srver machine under Windows server 2008, but a message, saying that some tools can't be installed due to missing microsoft tools, is displayed during installation. As a resulat the compiler is not integrated in my Visual Studio 2010 IDE.

Here is the message displayed:

Intel(R) C++ Compiler Professional Edition for Windows* modification can continue, but take note

The following components can not be installed: 
- Integration(s) in Microsoft Visual Studio* 
- Intel(R) Parallel Debugger Extension 
- Integrated Documentation 
Modification can continue; however, these components will not be installed because they require that a supported Microsoft* development tools be installed. Refer to the Release Notes for a list of the required Microsoft* development tools.

Can you please enlighten me about the source of the problem and how to overcome it.

Thank you in advance

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

>>...Can you please enlighten me about the source of the problem and how to overcome it.

Please take a look at Release Notes for the Intel C++ compiler v11.1.067 for a list of supported Visual Studios. It is possible that version 11 of Intel C++ compiler can not be integrated with Visual Studio 2010. Also, what Edition of Visual Studio do you use?

Thanks for your answer,

Yep, it seem to be the case, I have a higher C++ compiler's version (11.1.067 ) with respect to the version of the Visual Studio 2010(version:10.0.30319.RTMRel)

Hope this will help others 

>>...it seem to be the case, I have a higher C++ compiler's version (11.1.067 ) with respect to the version of
>>the Visual Studio 2010(version:10.0.30319.RTMRel)

Thanks for the update but it is still not clear what is Edition of Visual Studio 2010? Is it Express, Standard, Professional, etc?

Oh sorry, I thought you asked for the version,

My Visual Studio IDE and C++ Compiler are both Professional editions 

Kind regards

Hi Nadir,

According to 11.1 Update 9 release notes, 11.1 doesn't support VS 2010.  You need a lower version of Visual Studio.  See section 1.3 System Requirements in the release notes.

Thank you.
--
Feilong H.
Intel Developer Support

Tools Knowledge Base:  http://software.intel.com/en-us/articles/tools

>>...According to 11.1 Update 9 release notes, 11.1 doesn't support VS 2010...

I use Intel C++ Compiler XE 12.1.7.371 [ IA-32 ] ( Update 7 ) with Visual Studio 2005 Professional Edition ( PE ) but I have not tried to integrate the same version of the compiler with Visual Studio 2008 PE. I think it should work however I use 13.x version with VS 2008 PE.

Leave a Comment

Please sign in to add a comment. Not a member? Join today