Using Visual Fortran with Visual Studios

Using Visual Fortran with Visual Studios

Hi,

For the current project I am working on, I think I am going to need visual studios and the visual fortran compiler.  Because I am not sure if this is exactly what I need, I have downloaded the 30-day trial deals so I can verify that it works.  So far, I have not been able to get it to work, so that is why I am here.  Here is what I have done so far:

Downloaded a 30-day trial from Microsoft Visual Studios 2012 Ultimate (I also tried professional) and updated everything through Microsoft

Downloaded a 30-day trial for Intel Composer XE - for the Visual Fortran compiler

Visual Studios works just fine when I have NOT downloaded and installed the Fortran compiler, but I get an error when the compiler is downloaded and installed and even integrated with Visual Studios.  The error is: "Exception has been thrown by the target of an invocation."

I am not sure how to get passed this.  Any help would be much appreciated!!! 

(Also, I am operating on Windows 7).

Thanks,

Jen

13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

>>...Visual Studios works just fine when I have NOT downloaded and installed the Fortran compiler, but I get an error when
>>the compiler is downloaded and installed and even integrated with Visual Studios. The error is: "Exception has been
>>thrown by the target of an invocation."

It is Not clear if the error is from:

- Visual Studio, or
- Intel Visual Fortran for Windows compiler, or
- Your Fortran test application

Please provide more details.

I've seen this before but don't know exactly what causes it. Usually I can fix it by uninstalling Fortran and Visual Studio, deleting the Visual Studio folder from under Program Files, then reinstalling.

Steve - Intel Developer Support

I tried reinstalling and I get the same error.  Visual Studios works well without the intel visual fortran compiler, but again, when I install the fortran compiler I get the same error.  If you run visual studios with the compiler as the administrator, you get an error that looks like this:

'The 'MRU Package' package did not load correctly.  The problem may have been caused by a configuration change or by the installation of another extension.  You can get more infor by examining the file ActivityLog.xml'

So I went to the ActivityLog.xml and the error it was throwing was 'No InprocServer32 registered for package' \mscoree.dll

I am not exactly sure what this error mean.  Any insights?

Thanks for your advice.

Jen

Did you delete the Visual Studio folder between installations?

Steve - Intel Developer Support

Yes I did.  Do you know what might be causing this fortran compiler to not cooperate with visual studios?

I am using Visual Studios 2012 Professional and Intel Visual Fortran Composer XE (version 2013).

Jen 

No, I don't know. I have not seen this problem persist after a full uninstall and reinstall.  When do you see this error?  When you open VS? When you open a project?

Steve - Intel Developer Support

When I open VS itself.  When I install Intel Visual Fortran, some of the icons on my desktop even disappear when this compiler is installed.  I have been trying to install the compiler using the browsing method and now I am switching to the download manager.  Could that have an effect?

Jen

I wonder if you have something else going on with your PC, such as a disk or memory problem. Icons should not disappear. (The Intel Fortran install does not do anything with desktop icons.)

It certainly would be worth clearing your browser cache and using the other download method, though if the installer you downloaded was corrupted it should have failed the digital signature test Windows automatically applies. You may want to try a reboot as well before you reinstall.

Steve - Intel Developer Support

Got it to work.  It had something to do with the fact that it was exceeding the PATH variable on my computer.  I adjusted some settings and deleted some paths so the compiler had enough room to add to the PATH variable.

The path variable was getting to be too long that it was corrupting other environment variables like 'windir'.

Thanks for your help!

Jen 

Ah, yes. Windows has this annoying problem in that regard. Our latest installer tries to detect that it's an issue but can't always. Glad to hear that you figured it out.

Steve - Intel Developer Support

Now I have a different problem.  When running some code in debug mode, I get the following 'errors' that don't allow me to proceed and run my application.  Any work around solution?

'FAST-DWM.exe' (Win32): Loaded 'C:\Windows\SysWOW64\ntdll.dll'. Cannot find or open the PDB file.
'FAST-DWM.exe' (Win32): Loaded 'C:\Windows\SysWOW64\kernel32.dll'. Cannot find or open the PDB file.
'FAST-DWM.exe' (Win32): Loaded 'C:\Windows\SysWOW64\KernelBase.dll'. Cannot find or open the PDB file.
'FAST-DWM.exe' (Win32): Loaded 'C:\Windows\SysWOW64\imagehlp.dll'. Cannot find or open the PDB file.
'FAST-DWM.exe' (Win32): Loaded 'C:\Windows\SysWOW64\msvcrt.dll'. Cannot find or open the PDB file.
'FAST-DWM.exe' (Win32): Loaded 'C:\Windows\SysWOW64\advapi32.dll'. Cannot find or open the PDB file.
'FAST-DWM.exe' (Win32): Loaded 'C:\Windows\SysWOW64\sechost.dll'. Cannot find or open the PDB file.
'FAST-DWM.exe' (Win32): Loaded 'C:\Windows\SysWOW64\rpcrt4.dll'. Cannot find or open the PDB file.
'FAST-DWM.exe' (Win32): Loaded 'C:\Windows\SysWOW64\sspicli.dll'. Cannot find or open the PDB file.
'FAST-DWM.exe' (Win32): Loaded 'C:\Windows\SysWOW64\cryptbase.dll'. Cannot find or open the PDB file.
The program '[40348] FAST-DWM.exe' has exited with code 1 (0x1).

Jen

None of those are errors. All but the last line are informational messages that are not relevant to you. The last message says that the program completed. However, you don't see the output because Visual Studio closes the console window automatically.

If you simply want to run the application, select Debug > Start Without Debugging. This will leave the console window up at the end. If you want to debug., set a breakpoint at an executable statement and it will stop there.

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today