crashes of gemm on new Windows machine

crashes of gemm on new Windows machine

Don Ritchie's picture

I have just set up a new Dell XPS 8700 with an Intel(R) Core(TM) i7-4770 running Windows 7 Pro. I also have a Dell XPS 8100 with Intel's i7-860 running Windows 7 Ultimate, and a Dell Inspiron Notebook with Intel's i3-2350M running Windows 7 Home Premium.

All three computers have MS Visual Studio 2010 and 2012, and Intel® Visual Fortran Composer XE for Windows* 2013 w/MKL 11 (installed on top of the 2011 version with MKL 10). I've been running these on linear algebra applications. All of my apps compile and execute fine on both of the older machines, but I'm having problems on the new (XPS 8700, i-4770) one. These problems occur only after installation of the XE 2013/MKL 11, and not with XE 2011/MKL 10 using VS 2010.

Most simply, just doing a simple matrix multiplication using gemm in debug gives access violation code -1073741819 (0xc0000005). I see the same behavior on both VS 2010 and 2012.

Exactly the same program, with exactly the same Project Properties, runs without a problem on both older machines.

I've checked the Program Files (86)>Intel>Composer XE 2013>mkl>lib>intel64 contents of the new XPS 8700 with those of the XPS 8100 and see no differences.

Any suggestions will be appreciated.

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Gennady Fedorov (Intel)'s picture

Don, it might be the same issue like we had in http://software.intel.com/en-us/forums/topic/401556   with the 11.0 update 1. In the case if this is another case - would you give us the test case for checking the problem on our side? 

Don Ritchie's picture

Gennady:

You nailed it. I downloaded an evaluation copy of MKL 11.0 Update 5 and installed it. The program using gemm, and other programs using more mkl routines, now run without problems.

Since my subscriptions expired in September 2012, I gather that my options now are: (1) buy a new subscription; (2) uninstall the XE 2013 and use the 2011 version with mkl 10. Is that correct?

Login to leave a comment.