smpd version mismatch with only one version installed

smpd version mismatch with only one version installed

Hi,

I just installed the Intel MPI package for Windows on a new (Windows 8) laptop. Installation completed without issues and according to the task manager, the smpd service is up and running.

I have successfully written and compiled and MPI application but as a try to launch it, I get the error message

"Aborting: unable to connect to CAT, smpd version mismatch"

As I have just a single MPI version installed and am not connected to any "competing" machines this is quite confusing. Any ideas on how to resolve the issue would be much appreciated.

Thanks!

Cathleen

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Cathleen,

As a note, the Intel® MPI Library does not currently support Windows 8*.  It does work, but there are definitely issues.

About the application you are running.  Does it have any graphical components?

Are you able to run the provided test program?  It is in the installation folder, subfolder test.  Compile any one of the source files and try running the resulting executable under mpiexec.

What is the output from the command

smpd -get binary

You can try setting I_MPI_SMPD_VERSION_CHECK=disable to allow the program to run even with a mismatched SMPD.  You will still get a warning.

Finally, you can try using mpiexec.hydra instead.  This will use Hydra to launch the ranks instead of SMPD, which should provide overall performance benefits.  Keep in mind that this is still an experimental feature in Windows*

Sincerely,
James Tullos
Technical Consulting Engineer
Intel® Cluster Tools

I did a very simple text based little program, not unlike the provided test program so nothing fancy. Tried the provided test and that didn't work either.

I've now installed the runtime kit and that sorted everything out for me so I guess it was just some registry key or something that didn't get set correctly. Could be related to Windows 8 as you suggest, I never had any problems in Windows 7.

Speaking of the runtime kit though, according to the screen that pops up when you run the installer with --h, there should be a silent installation option if specifying --s. However, if I give the --s option, the GUI still opens. Am I misinterpreting how to use the silent flag or is there a bug here? I really rather need to be able to do redist installations without user interaction.

Thanks for your help!

Cathleen

Hmmm.  It appears that there are some problems with the silent installation at present.  For now, it can't be done in any ways that work on Windows* 7.  I'll be filing a bug report on this.

I'm afraid I have the same issue on Windows 7 as I do on Windows 8 when it comes to running the silent installtion.

I tested it on Windows* 7 and could not get a silent installation to work there either.  Our development team is investigating.

Ok, there are some options that aren't well described in the help dialog.  Here's what you need to be using for a silent installation:

w_mpi-rt_p_4.1.1.036.exe --s --a install --eula=accept --output=<log file location>

Leave a Comment

Please sign in to add a comment. Not a member? Join today