"SP1" name is misleading

"SP1" name is misleading

SP1 contains a significant number of breaking changes. It is much more like a new version than a service pack. I would expect bug fixes and non-breaking enhancements to be in a service pack.

  • The "upgrade" to TBB 4.2 causes me compiler errors
  • The "upgrade" to IPP 8.0 contains a new library file layout, forcing me to rewrite my build scripts
  • An entire compiler suite (MSVC 2008) was deprecated
  • The software update manager was installed automatically

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hello,

what compile error were caused by upgrading to TBB 4.2? are they covered by CHANGES file?

thanks,
--Vladimir 

Leave a Comment

Please sign in to add a comment. Not a member? Join today