problem with vtune amplifier

problem with vtune amplifier

Dear all, 

             I whave written bunch of FORTRAN 90 codes and compiled with ifort. I have made Makefile as follows.  

OBJECTS := co2_ads.o sub_change_pot.o sub_total_pot.o sub_del_pot.o sub_ins_pot.o sub_translationmove.o sub_rotmove.o sub_deletionmove.o sub_insertionmove.o sub_chempot.o sub_trans_sample.o sub_hmatrix.o global_mod.o constants_mod.o cavity_var.o ewald_mod.o sub_cavity.o sub_gasmolcavity.o sub_total_kspace.o sub_total_bonded.o sub_del_kspace.o sub_del_kspace1.o sub_kspace_ins.o 

co2_ads.x: $(OBJECTS)
ifort -o c.x -O $(OBJECTS)
%.o: %.f90
ifort -c $<
clean:
rm -f *.o *.mod

Then I executed ./c.x. However, I want to see which part of code among these codes are taking more time. For that I used Vtune profiler as with following command

amplxe-cl -collect hotspots /tmp/r001/ -- ./c.x

 I got an error as follows: 

amplxe: Error: Failed to start profiling because the scope of ptrace system call application is limited. To enable profiling, please set /proc/sys/kernel/yama/ptrace_scope to 0. See the documentation for instructions on enabling it permanently.
amplxe: Using result path `/home/satya/main-code/fmof-1-cal/r000hs'
amplxe: Executing actions 24 % Processing profile metrics and debug information
amplxe: Warning: Error 0x40000026 (Database interface error) -- Cannot run data transformation `Compute CPU Usage'.
amplxe: Executing actions 50 % Generating a report

Collection and Platform Info
----------------------------
Parameter r000hs
------------------------ --------------------------------------------------------------------------------------------------------------------
Application Command Line ../ewaldcavity-biased/c.x
Operating System 3.5.0-37-generic DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.10
DISTRIB_CODENAME=quantal
DISTRIB_DESCRIPTION="Ubuntu 12.10"
Computer Name darbari
Result Size 1027794

CPU
---
Parameter r000hs
----------------- ---------------------------------------
Name Intel(R) Core(TM) Processor 2xxx Series
Logical CPU Count 8

Summary
-------
Elapsed Time: 0.000
amplxe: Executing actions 100 % done

Can you please explain me, what could be the error I made. 

Thank you.

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

VTune Amplifier XE can't run Hotspots analysis if ptrace is set to non-zero.  As the error message says, you need to set it to 0 in /proc/sys/kernel/yama/ptrace_scope file.

Login to leave a comment.