How should I set GopPicSize GopOptFlag GopRefDist for TFF encode ?

How should I set GopPicSize GopOptFlag GopRefDist for TFF encode ?

I changed Media SDK 2013 sample_encode a little do TFF test,  and find the setting I use will cause B frames  Mosaic ?

1.  change code add

m_mfxEncParams.mfx.GopPicSize = 24; //24;
m_mfxEncParams.mfx.IdrInterval = 0;
m_mfxEncParams.mfx.GopOptFlag = MFX_GOP_STRICT;//MFX_GOP_CLOSED; //
m_mfxEncParams.mfx.GopRefDist = 3;//3;

before ResetMFXComponents();  line 918 pipeline_encode.cpp  (see attach file )

2. command argument use 

-d3d h264 -i "d:\\samples\\out\\00000.track_4113.264_1920x1080.yuv" -o "d:\\samples\\out\\out_Intel__.264" -w 1920 -h 1080 -hw -tff

out put file see out_Intel__.264 in attach rar file

3. there are may  B frames have Mosaic, such as 

display :                 70 frame (attach png)

4. the input yuv create by tsMuxeR gui 1.10.6 from demux a m2ts file 

5. sys_analyzer information

Intel Media SDK System Analyzer (64 bit)

The following versions of Media SDK API are supported by platform/driver:

Version Target Supported Dec Enc
1.0 HW Yes X X
1.0 SW Yes X X
1.1 HW Yes X X
1.1 SW Yes X X
1.3 HW Yes X X
1.3 SW Yes X X
1.4 HW Yes X X
1.4 SW Yes X X
1.5 HW Yes X X
1.5 SW Yes X X
1.6 HW Yes X X
1.6 SW Yes X X
1.7 HW Yes X X
1.7 SW Yes X X

Graphics Devices:
Name Version State
NVIDIA GeForce GT 640 9.18.13.1090 08
AMD Radeon HD 6800 Series 13.101.0.0 08
Intel(R) HD Graphics 4000 9.17.10.2932 Active

System info:
CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
OS: Microsoft Windows 7
Installed Media SDK packages (be patient...processing takes some time):

 Please help , Thanks

AttachmentSize
Download pipeline-encode.cpp46.82 KB
Download out-intel.rar8.33 MB
Download frame-70.png672.96 KB
12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,

The encoded stream certainly does not look good. 

Could you you please update to the latest graphics driver on you platform from here: https://downloadcenter.intel.com/default.aspx . There may be some issues with the graphics driver you're using so let's first try to eliminate that.

If that does not work, could you please share part of the raw YUV raw interlaced content so that we can try to reproduce issue on our side.

Regards,
Petter 

Sorry, 
I do not use "raw YUV raw interlaced" , I will test   "raw YUV raw interlaced" later
But cuda work fine, so does x264.

Will intel auto deal this converter in future?
Or its a bad idea? 

Regards,

LK

Hi LK,

Media SDK does not use any proprietary raw format. The input assumes plain progressive or interlaced raw surfaces YUV type surfaces.

If you can share part of your raw input we can look at it and try to help you determine potential format issues.

Regards,
Petter 

please unzip attach file

will get 00000.track_4113.264_1920x1080.yuv file about 1.78G

Regards,

LK

Attachments: 

Hi LK,

The raw file you provided is of YV12 progressive format and I do not see anything wrong with it.

Regards,
Petter 

Thanks Petter,

Back to the topic,
did you reproduce the  B frames  Mosaic situation?
Any recommand setting on how to  set code below?

m_mfxEncParams.mfx.GopPicSize = 24; //24;
m_mfxEncParams.mfx.IdrInterval = 0;
m_mfxEncParams.mfx.GopOptFlag = MFX_GOP_STRICT;//MFX_GOP_CLOSED; //
m_mfxEncParams.mfx.GopRefDist = 3;//3; 

Regards,
LK 

find similar topic ,http://software.intel.com/en-us/forums/topic/328246
do we have the same issue ?

Regards,

LK 

I was not able to reproduce the artifacts you're seing using the same configuration.

The other issue you refer to to connected with mixing progressive and interlaced frames. But as far as I can tell that is not what you're attemting to do?

Regards,
Petter 

Hi, Peter,

Sorry, I can use my sample_encode.exe produce every time,
Please check If you can repreduce by my exe, See attached file, Thanks.

C:\Program Files\Intel\Media SDK 2013\samples\_build\Win32\Release>sample_encode

.exe -d3d h264 -i "d:\\samples\\out\\00000.track_4113.264_1920x1080.yuv" -o "d:\
\samples\\out\\out_Intel__.264" -w 1920 -h 1080 -hw -tff
Intel(R) Media SDK Encoding Sample Version 4.0.553.52283

Input file format YUV420
Output video AVC
Source picture:
Resolution 1920x1088
Crop X,Y,W,H 0,0,1920,1080
Destination picture:
Resolution 1920x1088
Crop X,Y,W,H 0,0,1920,1080
Frame rate 30.00
Bit rate(Kbps) 3757
Target usage balanced
Memory type d3d
Media SDK impl hw
Media SDK version 1.4

Processing started
Frame number: 614
Processing finished
Frame number: 614

Regards,
LK 

Attachments: 

AttachmentSize
Download sample_encode.rar79.08 KB

Hi LK,

I do not see the any artifacts (with your input and parameters) using your executable either.  :(

Please make sure you have the latest graphics driver installed on your machine. The "2932" is a bit old.

I also noticed from your "sample_encode" log that you are not using the latest version of the Intel Media SDK. Please try to use the samples from the Media SDK 2013 R2 release.

Regards,
Petter 

Hi Petter,
     I uninstalled driver and OpenCL - CPU Only Runtime Package, and install  latest driver to 9.18.10.3257. 
Both   Media SDK 2013 and  Media SDK 2013 R2 works fine.
     Seems driver problem
     Thanks for your patient!

Regards,
LK 

Leave a Comment

Please sign in to add a comment. Not a member? Join today