media metrics all 0 on Windows 8.1 (ok w/ Windows 8)

media metrics all 0 on Windows 8.1 (ok w/ Windows 8)

Nikos D.'s picture

Hello.

I've recently installed your latest Intel GPA monitor tool 2013 R4 on my PC.

The platform is: Windows 8.1 Pro x64 - Pentium G3420 - iGPU GT1 (Haswell) - Driver version latest 3345 - No discrete card.

In the "About" menu of Intel GPA Monitor 2013 R4, it recognizes my Intel HD graphics and OS and says "Supports GPA Instrumentation"

But when I try to use the HUD with Media Performance metrics, like "MFX decode usage", or "VPP DXVA2" etc, none of them shows a value during HW accelerated video playback. Only the built-in FPS counter of HUD works.

I get the same null values for Media metrics when I use System Analyzer, too

Also my system often freezes and hangs-up after the use of GPA Monitor (random freeze which leads to hard-reset button in order to start-up)

Is my Pentium G3420 and my Intel HD graphics (4th generation graphics - Haswell GT1) supported by your latest GPA Monitor 2013 R4 ?

Why the HUD media performance metrics are not shown during video playback while using QuickSync hardware ?

Waiting for your feedback.

Regards,

Nikos

 

23 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Neal P (Intel)'s picture

Hello,

Yes, Intel GPA should fully support your configuration. Just to be sure, can you please copy the "About..." info here?

To help us understand the incorrect media metrics, can you describe in more detail what application you are running, and the sequence of events that you used so that we can duplicate the issue? Screen shots would also be helpful.

As to the freezes for Intel GPA Monitor, can you help me understand what you are doing when Intel GPA freezes? And when you say "freezes", does Intel GPA GUI stop working, or does it crash, or what exactly is happening?

Thanks!

Neal

Neal P (Intel)'s picture

Hello,

By the way, I just tried running Windows Media Player, and I see some of the media metrics working ok. Are you seeing all media metrics being "0", or just some of them that you believe should be non-zero?

Regards,

Neal

ps-> Note that i don't have your specific configuration, but was just trying 2013 R4 to see whether these metrics are completely broken in this release.

Nikos D.'s picture

Thank you for your reply.

I took the screenshot of the "About" and upload it in the attachments.

To measure the performance metrics I made a new profile named "Media Performance" and a new metric group named "Media metrics"

I run the default selection of Intel GPA "Analyze Application..." and run applications like mpc-hc and PotPlayer configured to use DXVA2 native.

Look at the second attachment

After I press run, I start playback of a 4K H.264 in HW using DXVA native.

Look at the third attachment.

As you clearly see , the 3 media metrics "EU Engine usage", "MFX Decode usage" and "VPP DXVA2" are all dead zero during all playback time.

Only the FPS meter is working and the "target App CPU load"

So it's not that every metric is not working. It's that media metrics are not working.

About the "frozen" situation, it's happening after the closing of the application without an error display, a "blue screen" or something obvious.

I get a complete stall, I can't move the mouse and every sign of the OS seems dead. So I had to hard-reset with the reset button.

I can't even press ctrl-alt-delete, because keyboard is dead too

Attachments: 

AttachmentSize
Download About.jpg74.9 KB
Download Application run.jpg292.94 KB
Download Running app.jpg443.7 KB
Nikos D.'s picture

After posting the above reply, the OS crashed again immediately after I closed MPC-HC and before even close Intel GPA monitor.

The crash has no signs of crashing.

Just everything stops working.

To be more exact the screen freezes completely.

I think it has something to do with the iGPU driver.

Neal P (Intel)'s picture

Hello,

I did some more checking, and it looks like there is a problem with media metrics that only occurs on the Windows 8.1 platform with Haswell graphics (which is what you have). Note that Windows 8.0 seems to be working ok.

I'm in the process of checking with the development team to see if they have any more information on this issue.

Regards,

Neal

Nikos D.'s picture

Hello.

I've just upgraded my old SandyBridge system Core i5-2400 from Win 8 Pro x64 to Win 8.1 Pro x64 with latest drivers installed 3347.

After the installation of Intel GPA 2013 R4, I have the same problem as above - no media metrics.

So the problem is general for every GPU with Win OS 8.1 and not just for Haswell.

Although, it seems that Sandy is not suffering from the sudden hang-ups, frozen Desktop issues.

Regards,

Nikos

Neal P (Intel)'s picture

Hello,

At this time we suspect an issue with the driver, so that any graphics h/w using the 8.1 driver will have this problem. In other words, I believe that both systems use the same driver, so you'll see the same issue on both systems.

However, it's good to hear that system freezes do not occur with the SandyBridge systems.

Regards,

Neal

Neal P (Intel)'s picture

Hi,

I'm following up on this with the driver team to see if there is any update on the status of this.

By the way, besides the problem with incorrect metrics, I'm particularly concerned about the system crashes. Do you have any updated info on this?

Regards,

Neal

 

Nikos D.'s picture

Hello and Happy New Year.

After the installation of latest GPA 13.4.215202, I saw no difference and improvement regarding Media Performance metrics.

Still, no Media Performance metrics are viewable in HUD or System Analyzer.

Moreover, I lost the ability to view HUD metrics in Window mode. Now only in Full Screen mode I can see the HUD. Why ? I find it very useful to see the HUD metrics in Window mode and I consider it as a bug introduced with latest version.

About the crashes/ freezes of GPA, I could say that some things have improved, but it's again extremely easy to freeze the desktop screen after running GPA latest version.

Do you think it's a drivers problem for both issues - Media metrics and crashes - or we need a new GPA version ?

Regards,

Nikos

Neal P (Intel)'s picture

Hello,

From your recent message:

  1. After the installation of latest GPA 13.4.215202, I saw no difference and improvement regarding Media Performance metrics. Still, no Media Performance metrics are viewable in HUD or System Analyzer. Do you think it's a drivers problem for both issues - Media metrics and crashes - or we need a new GPA version?
    • Yes, our latest analysis still shows that the Intel GPA product is getting all 0 metrics from the driver, but it's not clear whether the issue is the driver or the metrics collection from the OS. The team is working on this now (and yes, we have been able to duplicate this issue with 8.1, and as you mentioned Win8 is ok).
  2. Moreover, I lost the ability to view HUD metrics in Window mode. Now only in Full Screen mode I can see the HUD. Why ? I find it very useful to see the HUD metrics in Window mode and I consider it as a bug introduced with latest version.
    • This appears to be a new problem -- does this happen with just one app, or with everything? I'll try duplicating myself.
  3. About the crashes/ freezes of GPA, I could say that some things have improved, but it's again extremely easy to freeze the desktop screen after running GPA latest version.
    • Do you have some specific steps that we can follow to duplicate this? We haven't seen this before, and my attempts to duplicate the problem have not been successful. Do you know if this occurs only after running a specific app, or only after attempting to get media metrics?

Thanks for your patience with this. I will send more info on the status as I get the info from the development teams.

Regards,

Neal

Neal P (Intel)'s picture

Hi,

For your new issue of metrics only showing up in full-screen mode, I have not been able to duplicate this. I tried "gpasample.exe", and all works fine in windowed mode.

But I'm also wondering whether you have multiple D3D devices -- have you tried using CTRL-F5 to switch to see if the HUD appears? See this article in online help:
   http://software.intel.com/sites/products/documentation/gpa/13.4/win/hh_g...

Regards,

Neal

Nikos D.'s picture

Hi.

About the window mode, please try MPC-HC or PotPlayer. Window mode doesn't work with those two.

As a matter of fact, I always use those two Video Players for any check of Media metrics, along with DXVAChecker.

About the second problem with crashes, I even managed to cause a blue screen on Windows 8.1! This is rare.

Two examples:

First crash happened when I opened WMP through Analyze application, worked OK, I closed WMP from x button  (upper right window) and then immediately opened MPC-HC again through Analyze application. When I double clicked a file from the playlist of MPC-HC, system hanged-up.

Second crash - with a blue screen - happened when I closed MPC-HC during the opening of a file. You have to open MPC-HC through Analyze application, open a file and before the file opens - during opening operation - just close from the X of the upper right window.

These are very common procedures and I think that system shouldn't hang-up.

Neal P (Intel)'s picture

Hi,

Thanks for quick response for the additional info -- I'll try one of the these players to see if I can duplicate, and also try to get the system to freeze.

Regards,

Neal

 

Neal P (Intel)'s picture

Hi,

I sent you a private message on this, but for others that are watching this thread, here's an update: We believe that the system crashes/freezes occur with Intel GPA trying to analyze 32-bit apps when your platform is a win8/win8.1 64-bit OS.

I don't have an update yet on media metrics being 0 using the Windows* 8.1 OS.

I'll send more info as soon as we've been able to isolate this further.

Regards,

Neal

Nikos D.'s picture

Hello.

Any news, any progress about GPA and drivers fixes ?

Regards,

Nikos

Neal P (Intel)'s picture

Hello,

I'm testing out some driver fixes that should resolve the freezes and OS crashes.

We're still trying to identify where the media metrics get "lost" -- there are quite a few pieces (driver, OS, ...), and testing has failed to isolate exactly where things go bad.

Thanks for your patience while we get these fixed.

Regards,

Neal

Nikos D.'s picture

Hello again Neal.

It's been 2 months from my first post regarding GPA issues and I would like to inform me which is the progress on that matter.

I haven't seen any new drivers since then (v3345 are still latest) and no new GPA version.

Will the new drivers/ GPA resolve that problem ?

Do you have an ETA to give me ?

Regards,

Nikos

Neal P (Intel)'s picture

Hello,

Fixes for these issues have not been released. I will follow-up with a private message with more information on this.

Thanks again for your patience on this!

Regards,

Neal

Nikos D.'s picture

Hello Neal.

A new driver is out officially from Intel here: https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23639

Unfortunately even with 3412 drivers, all problems are present:

1) Crashes/ Freezes

2) No media metrics

3) No HUD display in window mode.

Does this mean that we have to wait another 4 months for a new driver update ?

Neal P (Intel)'s picture

Hello,

We are awaiting a driver fix for this issue -- at this time I don't have an estimated date for it's availability.

Thanks for your patience with this.

Regards,

Neal

Eugene Y.'s picture

We ran into the same problem on Windows 8.1. Do you have any update at this point?

Neal P (Intel)'s picture

Hello,

Unfortunately I have no further information as to when a fix will become available.

Regards,

Neal

Login to leave a comment.