MJPEG decode fails on Windows app store Camera applications

MJPEG decode fails on Windows app store Camera applications

Hello

I'm developing device driver for webcam that supports MJPEG

It works fine with YUV/RGB but there is a problem using MJPEG 1280x720 only on  Windows app store applications (Metro)

Sometimes the video is stuck or showing black frame (and sometime it works OK)

When using  MJPEG 1280x720 in Desktop applications (both Direcshow and Media foundation apps) - it works fine.

I've discovered that when I disabled the dll mfx_mft_mjpgvd_64.dll  (rename) - it works perfectly also on Metro applications.

How can I understand the root cause of this issue? How can I debug or fix this issue?

 

Thanks

Haim.

 

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,

We've had a few reports of similar 'intermittent' issue and we are looking at it.

I am curious, is the MJPEG steam being used coming from a live camera, or is it a file?

If it is a file, could you please provide it, as this would assist our debug efforts?

THANKS

-Tony

Hi
Actually it's live video - not a file

I'll try to record some video frames (jpeg)

Can you suggest some workaround?

Thanks

Haim

Hi, 

I'll contact you, as you may be able to help us here.  THANKS

-Tony

Hi

As a temporal workaround for this issue, what is the preferable way to disable HW MJPEg decode? I know about the registry key HKLM, Software\Microsoft\Windows Media Foundation\HardwareMFT\EnableDecoders that can be set to 0.

Thanks

Haim

HI Haim,

As mentioned in private messages, we would prefer that globally disabling the certified MFT not be done for issue seen with this one applications, but it is option for temporal/debugging purposes.  We are continuing to investigate why we are seeing an issue for this application.

-Tony

Login to leave a comment.