SP1 Update 2: error PRJ0019: A tool returned an error code

SP1 Update 2: error PRJ0019: A tool returned an error code

Never before I had so much trouble in downloading a new version of Intel Composer XE as with the most recent version SP1 update 2). I did not manage to download the full offline installer packages for the C/C++ and Fortran parts. During download I always received error messages indicating a server timeout, at workdays, at the weekend, at different times of the day, at different stages of the download. I finally managed to install the new version by using the online installer, with server timeout messages as well. But the online installer seems to be able to repair such problems, so the installation was finished successfully. That's what I assumed. I was wrong.

During the first test with the Fortran compiler I received the message "error PRJ0019: A tool returned an error code". What could be the cause for the message? What went wrong during installation? How can I fix the problem? I use Windows 7 Pro 64bit, VS 2012 Ultimate (German version).

 

18 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Did it build OK though? I often get that message from the manifest tool on a random basis, I think it is my virus checker causing a problem. Try switching it off to test that theory.

I've had the experience of requiring the download manager for the Windows compiler, even though I should have better connection to the server.  Windows online installation seems a tough route when you can't maintain a connection as if you were inside Intel.

I too did nearly everything else wrong on this update.  Although it offered to replace the update 1 compiler, taking that path seemed disastrous.  I've ended up needing to remove the Intel compilers and visual studio (2012 pro) and start over.  I wasted time on VS repair; I think you must remove it entirely and install the basic and service pack.  It should remember your C++ configuration. So I've been at it for 2 days.

I also frequently get the "tool returned an error code" message. It does not have anything to do with what version I am using or when I downloaded it etc. For a particular project it can be stopped by switching off the manifest tool, as app4619 suggested.

In VS: Project > Properties > Linker > Manifest File, "Generate Manifest" set to No

Or on command line: /MANIFEST:NO

But I don't know how to save this setting as a default for new projects, so I ALWAYS get the warning at least once. What a nuisance!

There have been complaints on this forum before, but the answer seems to be that it is Microsoft's default and Intel cannot do anything about it.

The procedure of removing the Intel compilers, cleaning up the Windows environment settings, removing and re-installing vs2012, then installing update 2, was successful for me. 

@dboggs: I am sorry to say that clearing the manifest generation did not resolve my problem.

I suspect that I have to repeat the installation of the compilers, including deinstallation and removal of all entries in the registry and folders, or even to reinstall VS 2012. Maybe one of the wizards at Intel has a better idea what to do. I remember that Steve Lionel mentioned "installation issues" in a recent post concerning the update 2.

I didn't notice any problems at the registry level which weren't taken care of by the standard removal.  I did have problems with the environment variable list outgrowing the limits, as several previous Intel tool uninstalls had left a lot of them behind.

When I look at the PATH on win8.1 after getting things working, it still looks like the compiler has failed to observe that Intel MPI is already on PATH and has added the coarray support in a conflicting way.  So there is no point in having the Intel MPI permanently on PATH, as it would have to be added again after setting up the ifort PATH.

I filed an issue several weeks ago about not being able to run Inspector on win8.1.  I think the support team is right, that it's a problem with the PATH setup which may be peculiar to win8.1.  In that case, the PATH we get by installing ifort after Inspector may be OK, but updating Inspector after ifort may cause it to fail at run time.

I finally managed to download the full offline installer packages for C/C++ and Fortran, without server timeout messages. I deinstalled all versions of Composer XE, and reinstalled the packages again. No error messages occured, everything seems to be ok. But the error message during  compilation of every source file (see above) persists. What can I do to get rid of the annoying malfunction? Reinstalling the whole VS 2012 package?

You need to look at the buildlog.htm to see exactly where in the build process this error occurred. In most cases it is from mt.exe, the Manifest Tool. If so, it will have an additional error message in the log that should be helpful.

Steve - Intel Developer Support

buildlog.htm of the source file GETERR.FOR has the following content:

Compiling with Intel(R) Visual Fortran Compiler XE 14.0.2.176 [IA-32]...
ifort /nologo /debug:full /Od /QxHost /Qsave /Qzero /module:"Debug/" /object:"Debug/"/Fd"Debug\vc110.pdb" /traceback /check:bounds /libs:static /threads /dbglibs /winapp /c /Qvc11/Qlocation,link,"C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\\bin"
"D:\Progtools\Geterr\GETERR.FOR"

Geterr : error PRJ0019: A tool returned an error code

I am not able to recognize anything peculiar. What do you think, Steve: reinstall VS 2012 and the new Composer XE?

 

I don't know how long it will last, but my update on win8.1 broke again (VS libraries not found by ifort, because CL not visible on VS nor on ifort command line, even though VS could perform GUI rebuilds).  Removing VS2012 (repair not completing) and reinstalling, then performing a "Modify" on ifort corrected the problem. 

rase,  I would next try doing that compile from the command line, using the exact command shown in the log.

Steve - Intel Developer Support

Steve, thanks for your help. Although I am a IVF user for many years now I never used the command line, and do not know how to do that. Rather than fiddling around in the mist I would prefer to get to work as soon as possible. Is the way you prescribed to me in a post last year (deinstalling VS 2012 and Composer XE, get rid of the traces in the registry, reinstalling VS 2012 and Composer) a possible and fast solution to my problem?

I am very doubtful that has any bearing on your problem. If you wish to attach a ZIP of your project with the sources necessary to build GETERR.for, I'll see if I can reproduce the problem.

Steve - Intel Developer Support

Hello Steve: I forgot to tell that the strange error message is issued during compilation of any Fortran source, regardless of  the project it belongs to. That's why I suspected the problem in VS or Composer, or the the traces the new version has left somewhere. I will try to attach a file with a two-line source "Hello world" program and project I usually execute after the installation of a new update to check the if everything went ok (I apologize in advance if I fail to transmit the file, I have never done that).
 

Attachments: 

AttachmentSize
Download Hello.zip3.21 KB

Ok - it looks as if the compiler is completely failing to run. Please uninstall Fortran, delete the Program Files (x86)\Intel\Composer XE 2013 SP1 folder, then reinstall and see if the problem persists. I also suggest checking the value of the PATH environment variable to make sure it doesn't contain extraneous or redundant entries.
 

Steve - Intel Developer Support

Thanks a lot, Steve. I deinstalled the C/C++ and Fortran compilers, removed the Intel Composer directories in the programs folder, deleted the Composer-related system environment variables, and cleaned the registry. After reinstallation using the full offline packages of Composer XE everything is back to normal. What I did not expect: all my settings of the general options of VS/Composer are still present, for example the include and library files for Winteracter.

Glad to hear it. I wish I understood why these things happen, but the important thing is that they can be resolved.

The list of include and library folders is in a separate registry tree under Visual Studio and that is preserved on an uninstall.

Steve - Intel Developer Support

Leave a Comment

Please sign in to add a comment. Not a member? Join today