"internal error" when building for Iris pro 5200 on Mac OS X

"internal error" when building for Iris pro 5200 on Mac OS X

Hi,

I'm trying to get some kernels running on the Iris pro 5200 in my new late 2013 macbook pro 15". The kernel works fine on Windows with my 3rd gen i7 CPU as well as my GeForce GTX 760. However, on Mac OS X 10.9/Xcode5 I keep getting an "internal error" when building my kernel from source:
The exact debug output from within clBuildProgram is

[CL_DEVICE_NOT_AVAILABLE] : OpenCL Error : Error: Build Program driver returned (10015)

OpenCL Warning: clBuildProgram failed: could not build program for 0x1224500 (Iris Pro) (err: -2)

[CL_BUILD_ERROR] : OpenCL Build Error : Compiler build log: Error: internal error.

I found that when I remove some lines of code from one of the device functions the kernel build fine, but obviously it won't work correctly then. So far I haven't found a way to reimplement my code to work around this issue. Before I spend time on creating a stripped down version of the particular problem I have some questions of a more general nature:

Is there some way to produce more logs? (The CL_PROGRAM_BUILD_LOG just reads "Error: internal error.")

Can I look up the meaning of this 10015 error code somewhere?

Is my Intel OpenCL driver for Mac updatable?

Is it more likely that the same errors will occur when I run it with the Iris card on Windows (I dont't have a PC with the Iris graphics card just yet) or is there a good chance that it will just work?

 

Thanks in advance for your insights.

1 post / 0 new
For more complete information about compiler optimizations, see our Optimization Notice.