configuration of external bridge network

configuration of external bridge network

Satoshi Ohshima's picture

Hi, all.

I'm trying to configure external bridge network using examples from MPSS_Users_Guide.

I want to access host CPU and MIC from other PCs at the same subnet network.

Then, I wrote ifcfg-br0 file as follows

DEVICE=br0
BOOTPROTO=none
ONBOOT=yes
IPADDR=<IP_A>
NETMASK=255.255.255.0
TYPE=Bridge
MTF=9000

and executed following commands

micctrl --addbridge=br0 --type=external --ip=<IP_A> --netbits=16 mic0
micctrl --network=static --bridge=br0 --ip=<IP_B>

(micctrl --network=static --bridge=br0 --ip=<IP_B> --netbits=16 mic0 cause warning and the same incorrect result is obtained)

After that, network and mpss services are restarted.

Then, IP address of each network interfaces are as follows

# ifconfig | grep -e "Link " -e "inet "
br0       Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx
          inet addr:<IP_A>  Bcast:<IP_A_Bcast>  Mask:255.255.255.0
eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx
          inet addr:<IP_C>  Bcast:<IP_A_Ccast>  Mask:255.255.0.0
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
mic0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx

As a result, I confirmed that I can login to CPU and MIC by ssh from host CPU.

However, from other PCs, I can login to CPU but I can't login to MIC.

Would you show me the correct procedures of network configuration ?

 

Kind regards

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Satoshi,

It sounds like forwarding is not enabled in your system. Can you check the output of the following command?

/sbin/sysctl net.ipv4.ip_forward

If return value is 0, then enable forwarding by executing the following:

/sbin/sysctl -w net.ipv4.ip_forward=1

If it still doesn't work, please check your firewall settings, in particular, the FORWARD CHAIN policy. Forwarding between the host and the mic should be allowed.

Hope it helps.

Best regards.

 

Satoshi Ohshima's picture

Thank you for your comment.

It was true that I didn't configure the net.ipv4.ip_forward parameter. Then, I modified the parameter and tried to configure mic. However, I still can not login to mic0.

Here is my current IP configurations:

br0       Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx
          inet addr:<IP_A>  Bcast:<IP_A_BCAST>  Mask:<IP_A_MASK>
eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx
          inet addr:<IP_C>  Bcast:<IP_C_BCAST>  Mask:<IP_C_MASK>
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
mic0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx

While I think I can login to mic by connecting <IP_A>, I accessed the host CPU.

Do you have any solutions?

Thanks, Satohshi OHSHIMA

 

FYI, these are of my ifcfg-* files:

# cat ifcfg-mic0
DEVICE=mic0
ONBOOT=yes
NM_CONTROLLED="no"
BRIDGE=br0

# cat ifcfg-br0
DEVICE=br0
BOOTPROTO=none
ONBOOT=yes
IPADDR=<IP_A>
NETMASK=<IP_A_MASK>
TYPE=Bridge
MTF=9000

This is my iptables rules. Do I need to configure some rules? (There are no rules on MPSS_Users_Guide.)

# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

 

I think you should connect straight to the mic console to see if the network configuration is ok. First of all ensure your mic is online:

micctrtl -s mic0

After, connect via minicom software to device /dev/ttyMIC0 with Bps/Par/bits = 57600 8N1 (this works for me) and try to do an ifconfig to see if the network interface is properly configured.

Satoshi Ohshima's picture

Thank you Bsc, but this problem was my stupid mistake! I forgot to re-configure the user account after using micctrl --initdefaults. My network configuration has no problem. In addition, I confirmed that net.ipv4.ip_forward=1 is NOT required when only I login to mic by ssh, and it is required when mounting external nfs directory.

Anyway, thanks for your help!

Hi - I think I went through the same problems in an earlier topic - 490138.  I tried to leave a comment yesterday, but maybe it doesn't like URLs.  If you check that topic, you will see that we did solve it and it all works for us now - with limitations on commands you can use.  Have a look at my comments in that topic - you will need to specify the correct gateway on the phi co-pros themselves...they default to zero.  Tho' it was all tested on MPSS 3.1.

Login to leave a comment.