Visual Studio 2012 pro - installing 'old' IVF

Visual Studio 2012 pro - installing 'old' IVF

Corporate policy is forcing me to switch to a Windows 7 64-bit platform. I have a new workstation with Visual Studio 2012 Pro installed on it.

On its intro page, when first starting it, I selected it to configure for Visual C++.

At present I run IVF on Visual Studio 2005. The IVF is an 'old' version - here are the details from the Help..About. in Visual Studio

Intel(R) Visual Fortran Composer XE 2011 Update 10 Integration for Microsoft Visual Studio* 2005, 12.1.3530.2005, Copyright (C) 2002-2012 Intel C

I have dowloaded w_fcompxe_novsshell_2011.10.325.exe and tried to install the compiler.

A package name w_fcompxe_2011.10.325 is also mentioned there.

However, when I try the installer, after a couple of  pages, I get the folowing messages that certain 'development tools' are missing:
  The Intel(R) Composer XE 2011 requires that a Microsoft* development product be installed.  Refer to the Release Notes for a list of the required Microsoft* development tools.
Installation can continue; however, you will have to configure Compiler scripts for command line build environment by hand if you want to use them. Refer to documentation for instructions how to do it.

  The following components can not be installed:
          - Integration(s) in Microsoft Visual Studio*
          - Intel(R) Parallel Debugger Extension
          - Integrated Documentation
Installation can continue; however, these components will not be installed because they require that a supported Microsoft* development tools be installed. Refer to the Release Notes for a list of the required Microsoft* development tools.

I am none the wiser as to what 'development tools' are missing.
Please can you advise?

Is it a permissions problem?

regards

 

:

 

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Steve Lionel posted the list of which ifort versions go with which Visual Studio versions a while ago.  You appear to have chosen a version which was developed before Visual Studio 2012 was available; you could confirm by consulting the release notes.  The bigger download version (without novsshell in the name) would be capable of installing VS 2010 Shell for GUI mode and operating independent of Visual Studio.

As the messages indicate, VS2012 would work only for command line with this ifort, after you modify the paths.

I think that what is happening is that the IFort installer is unable to integrate with VS 2012 because the latter is newer and did not exist when the installer and the IFort package were released. The release notes for the IFort version that you are trying to install will tell you which version of VS it is compatible with.

You will need to match the IFort with a compatible version of VS or, if command-line development is sufficient for you, modify the set up files ifortvars.bat, etc., with the correct locations of the VS tools (linker, librarian, obj-file dumper, etc.) and libraries.

Steve - Intel Developer Support

Thanks for the info.

It looks like I will have to upgrade my compiler version to go with the new VS2012 on the new workstation.

Leave a Comment

Please sign in to add a comment. Not a member? Join today