Installation problem: 32-bit libraries not found on this system on Ubuntu 14.04 LTS

Installation problem: 32-bit libraries not found on this system on Ubuntu 14.04 LTS

Hi all,

Ijust installed Ubuntu 14.04 LTS to my 64bit laptop.

I downloaded Intel Fortran Composer XE for Linux - Version 2013 SP1.

During the installation I got "Unsupported operating system error" but I skipped it.

Later, I get :

Missing optional prerequisites
-- 32-bit libraries not found

error.

I followed the instructions given in:

https://software.intel.com/en-us/articles/using-intel-compilers-for-linu...

I searched a lot.

My problem is same with this topic:

https://software.intel.com/en-us/forums/topic/270143

But I could not solve my problem and I am sure that I have 32bit libraries but I dont know where is my mistake :/

 

If you can help me for overcome this problem, I will be glad.

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Citation :

I am sure that I have 32bit libraries 
On what grounds?

Here is a simple test: write a short C program, and compile it to an a.out file using "gcc -m32 <filename.c>" and see if that command completes successfully. If not, you need to download the necessary packages for your version of Linux before you can get IFort to work.

I'm using Debian and also get the "32-bit libraries not found" message, but there's an option to skip the prerequisite and proceed with the installation.

I do have 32-bit support set (i.e., the "dpkg --print-foreign-architectures" command returns i386), and gcc/g++/gfortran multilib packages are installed.

So I suppose the message is due to the installer looking for specific libraries at {/usr}/lib32 instead of {/usr}/lib/i386-linux-gnu.
 

If you don't want to install the g++ -m32 support, the basic g++ 64-bit installation is sufficient to support the ifort installation when you deselect ia32.   

@mecej4:

Thanks for your suggest.

I said "I think I am sure that I hv 32bit libraries", because I followed the instructions and downloaded ia32-libs. In addition, I also check 32bit libraries are installed in Synaptic Package Manager.

This link helped me for that:
http://wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10

On the other hand, I did what you say and I am able to compile a C source code to the a.out.

@John:

Thanks for the information.

I checked "dpkg --print-foreign-architectures --> command returns i386". It also worked :)
I think you're right. Maybe the installer is looking for specific libraries.

Well, did you get any error while try to compile/use 32bit things?

@Tim Prince:

Well, I saw that Fortran 2013 Composer has an option to download for either 64bit or 32 bit on intel website unlike for Fortran 2013 Composer SP1.
I read almost same advice as yours in another forum but you know to know something is wrong makes me hesitated.

Thanks everyone once again. Well, I am new to both Linux and Fortran (therefore, my words can be seem meaningless to you) and I am trying to learn as much as I can (includes errors and how to overcome :), that's why I dont want to install only 64bit version ).

Hi,

Compiling a simple example seems to work properly:

...:~$ echo $LD_LIBRARY_PATH

...:~$ cat hello.f90 
print *, 'Hello, world!'
end

...:~$ . /opt/intel/bin/compilervars.sh ia32
...:~$ echo $LD_LIBRARY_PATH 
/opt/intel/composer_xe_2013_sp1.2.144/compiler/lib/ia32:/opt/intel/composer_xe_2013_sp1.2.144/mpirt/lib/ia32:/opt/intel/composer_xe_2013_sp1.2.144/ipp/../compiler/lib/ia32:/opt/intel/composer_xe_2013_sp1.2.144/ipp/lib/ia32:/opt/intel/composer_xe_2013_sp1.2.144/compiler/lib/ia32:/opt/intel/composer_xe_2013_sp1.2.144/mkl/lib/ia32:/opt/intel/composer_xe_2013_sp1.2.144/tbb/lib/ia32/gcc4.4
...:~$ ifort -m32 hello.f90 
...:~$ file a.out
a.out: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.32, BuildID[sha1]=e7a580ddf63a1153688f739ffa3ea603e63fa26f, not stripped
...:~$ ldd ./a.out 
	linux-gate.so.1 (0xf774a000)
	libm.so.6 => /lib/i386-linux-gnu/i686/cmov/libm.so.6 (0xf76d6000)
	libpthread.so.0 => /lib/i386-linux-gnu/i686/cmov/libpthread.so.0 (0xf76b9000)
	libc.so.6 => /lib/i386-linux-gnu/i686/cmov/libc.so.6 (0xf750e000)
	libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf74f2000)
	libdl.so.2 => /lib/i386-linux-gnu/i686/cmov/libdl.so.2 (0xf74ed000)
	/lib/ld-linux.so.2 (0xf774b000)
...:~$ ./a.out 
 Hello, world!
...:~$

 

Hi,

I use Ubuntu 14.04 and followed the same set of instructions from

https://software.intel.com/en-us/articles/using-intel-compilers-for-linu...

Here is a sum up of what I did:

1) I changed the install location to:

Install location:
    /home/foo/intel/composer_xe_2013_sp1.3.174

 

 

2) The components available are (what I installed):

Component(s) selected:
    Intel(R) Fortran Compiler XE 14.0 Update 3                             261MB
        Intel Fortran Compiler XE                                              

    Intel(R) Debugger 13.0                                                 223MB
        Intel Debugger                                                         

    Intel(R) Math Kernel Library 11.1 Update 3                             578MB
        Intel MKL core libraries                                               
        Fortran 95 interfaces for BLAS and LAPACK                              
        GNU* Compiler Collection support                                       

    GNU* GDB 7.5                                                            52MB
        GNU* GDB 7.5 on IA-32 (Provided under GNU General Public License v3)   
 

compared to what was given on their website (see above), I do not have:

Intel(R) Xeon Phi(TM) coprocessor support  ( under the MKL) and

Intel(R) Integrated Performance Primitives 8.1 Update 1                2.8GB
        Intel IPP single-threaded libraries                     

                

    Intel(R) Threading Building Blocks 4.2 Update 4                         77MB
        Intel TBB                                                               

    GDB Eclipse* Integration on Intel(R) 64 (Provided under Eclipse Public  
License v.1.0)

3) Finally, I did not have the option of:

Step 5 of 7 | Options > Architecture selection

Target Architecture(s) of your applications:
--------------------------------------------------------------------------------
1. [x]    IA-32
2. [x]    Intel(R) 64

It looks like I do not have ifort ( since which ifort in terminal gives back nothing and typing ifort I get ifort: command not found). Here is what I have in above install location:

/home/foo/intel/composer_xe_2013_sp1.3.174/composer_xe_2013_sp1.3.174/bin$ ls
compilervars_arch.csh    compilervars.sh   idbvars.sh
compilervars_arch.sh     debuggervars.csh  ifortvars.csh
compilervars.csh         debuggervars.sh   ifortvars.sh
compilervars_global.csh  ia32              loopprofileviewer.jar
compilervars_global.sh   idbvars.csh       sourcechecker

Could anyone please help me with getting ifort to work/

Thank you so much!

You need to use the "source" command to make the compiler available. Since you moved the install location you would use:

source /home/foo/intel/composer_xe_2013_sp1.3.174/composer_xe_2013_sp1.3.174/bin/ifortvars.sh intel64

Though I would have expected to see an "intel64" folder under bin if this is a 64-bit system.

Steve - Intel Developer Support

Hi,

The "32-bit libraries not found" message still happens during installation of version 15.0.0 of the compiler, although it can be skipped.

After installation, the test I posted above (#6) still works, so the libraries detection issue is only in the installer.

Also, even though I'm using Debian Testing, and I know that it's an unsupported OS, it's worth mentioning that the text installer (i.e., install.sh) segfaults, and only the GUI installer works.

 

Leave a Comment

Please sign in to add a comment. Not a member? Join today