Cilk view got error with program compiled by GCC 4.9.0

Cilk view got error with program compiled by GCC 4.9.0

Hi,

Recently, I have been compiling my Cilk plus program with GCC 4.9.0. Then I ran Cilk view to measure its parallelism and got this error:

Cilkview: Generating scalability data

Cilkview Scalability Analyzer V2.0.0, Build 3229

C:Tool (or Pin) caused signal 11 at PC 0x7f9124cd1dd3

 

Interestingly, when I compiled the program with GCC 4.8.2 and ran it with Cilk view again, it ran fine. So does it only happen with GCC 4.9.0? My guess is that GCC 4.9.0 isn't stable enough or not compatible with Cilk view at this time.

Thanks, 

1 post / 0 new
For more complete information about compiler optimizations, see our Optimization Notice.