Warning (528): IEEE_Underflow is signaling

Warning (528): IEEE_Underflow is signaling

How can I prevent the pop up message window "Warning (528): IEEE_Underflow is signaling"? I am using IVF 14.0.3, IMSL 7.0.1, compiler settings fpe:0, and using the MKL libs option. The main program USES imsl_v7 which is just

module imsl_v7

include 'link_fnl_static.h'

end module imsl_v7

The program runs fine but I get the message at the end which I don't want.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Are you compiling with /standard-semantics ("Enable Fortran 2003 semantics")? If so, you'll get this message. To turn it off, add:

/assume:nofpe_summary

under Fortran > Command Line > Additional Options

Steve

That worked.

Thanks Steve L.

Great. By the way, please go to your Dashboard (click on your user ID in the upper right corner and select Dashboard), then go to Profile and select a "Display Name" that isn't your email address. This will prevent your email address from showing here in the forum.

Steve

Login to leave a comment.