installing mpss | mic module issue

installing mpss | mic module issue

Mourad B.'s picture

Hi Everyone,

Need some help installing mpss on my Intel Xeon Phi machine:

mpss-3.2.1 with RedHat-6.5.

lspci | grep coprocessor
08:00.0 Co-processor: Intel Corporation Xeon Phi coprocessor SE10/7120 series (rev 11)

Issue:

micctrl --initdefaults
Error getting SCIF driver version
[Warning] No Mic cards found or specified on command line

Thanks for your help.

 

MrB
3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Frances Roth (Intel)'s picture

First - I strongly recommend that you download the latest version (mpss-3.2.3) release last Friday and use that instead of the 3.2.1. It has a number of important updates

My recommendation would be to uninstall the version you now have on your system - this is necessary for a clean install of the new version. Download the new version, untar it and install the rpm files following the directions in the readme file. then (step 5 in the install directions in the latest readme file) load the mic.ko driver using 'modprobe mic' and try your 'micctrl --initdefaults" command again. If you get the SCIF error message again, check to see if loading the mic.ko driver caused a warning message - you can use 'dmesg | less' and look for a message like "mic 0000:83:00.0: device not available (can't reserve [mem 0x00000000-0x1ffffffff 64bit pref]) pci_enable failed board #0" This would mean that you need to change the BIOS on your host to enable support for large (>4GB) mapped memory. If that doesn't solve the problem, there are a couple other things to try. If you look at https://software.intel.com/en-us/forums/topic/393956, you will find a troubleshooting flow chart that might help. Let us know how it goes.

Mourad B.'s picture

Thanks Frances,

very helpful :) I could install it and I am playing with some applications.

Thanks

 

 

MrB

Login to leave a comment.