Error: sampling collector failed to collect data because the selected event(s) did not occur

Error: sampling collector failed to collect data because the selected event(s) did not occur

<p>&nbsp;Hello sir,</p>

<p>&nbsp; &nbsp;&nbsp; I am analyzing some executable files using VTune 9.1 performance analyzer. I am selecting counters to analyze particular events. After analyzing some executable files(5 second,10 second,15 second and 20 second&nbsp; data files), counters related memory load operations(MEM_LOAD_RETIRED.L2_HIT, MEM_LOAD_RETIRED.L2_MISS)&nbsp; are stopped working. An error has occured that is "Failed to create sampling data base. Probably .tb5 files are corrupted or don't exist". Earlier these counters related to memory operations were working properly for 5 second,10 second and 15 second&nbsp; data files.While analyzing the 20 second data file, this error occured . And now those two counters are not working for any of the data files. And leaving these two counters, remaining counters are working well now. Can you please help me to enable these two counters related to memory load operations to analyze the files better.</p>

<p>Thanking you in advance.</p>

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

If you have updated your OS (how are we to guess which one) or compilers you probably should be updating VTune as well.

Did you rule out any of the suggestions offered in past posts on this question?

iliyapolak's picture

Probably from the hardware POV the counters are working.

Try to consult this link:

https://software.intel.com/en-us/forums/topic/300875

It would be really good to upgrade the tool to VTune Amplifier XE and see if the problem exists. BTW - what is CPU you are tuning on?

Thanks & Regards, Dmitry

iliyapolak's picture

Dmitry is right I have overlooked that you are running the old version of VTune amplifier.

Peter Wang (Intel)'s picture

VTune(TM) Performance Analyzer 9.1 is out-of-date product, there is no technical support for now. Please use VTune(TM) Amplifier XE 2013.

Other tip is, VTune 9.1 doesn't support current microprocessors since it was launched for several years. If you are lucky (I mean if there is no OS dependent) - hotspots & call graph might work. 

Login to leave a comment.