Running OpenCL on MIC got error, but CPU is fine.

Running OpenCL on MIC got error, but CPU is fine.

Hi,

I'm a beginner to OpenCL, and I want to run it on MIC. I download the monte-carlo example from the below url:

https://software.intel.com/en-us/vcsource/samples/monte-carlo/

Run it on CPU if fine, but when I choose to run it on MIC, it goes wrong. Some one could help?

 

MonteCarlo]$ ./montecarlo -d 1
WARNING: All config files need .conf: /etc/modprobe.d/unsupported-modules, it will be ignored in a future release.
WARNING: /etc/modprobe.d/unsupported-modules line 1: ignoring bad line starting with 'allow_unsupported_modules=1'
FATAL: Error inserting nvidia (/lib/modules/2.6.32-358.el6.x86_64/kernel/drivers/video/nvidia.ko): No such device
Platforms (1):
    [0] Intel(R) OpenCL [Selected]
Devices (4):
    [0]       Intel(R) Xeon(R) CPU E5-2697 v2 @ 2.70GHz
    [1] Intel(R) Many Integrated Core Acceleration Card [Selected]
    [2] Intel(R) Many Integrated Core Acceleration Card
    [3] Intel(R) Many Integrated Core Acceleration Card
./montecarlo: relocation error: /opt/intel/opencl-1.2-4.4.0.117/lib64/libmic_device.so: symbol COIProcessSetCacheSize, version COI_1.0 not defined in file libcoi_host.so.0 with link time reference

 

If I run it on CPU, it is OK.

 MonteCarlo]$ ./montecarlo 
WARNING: All config files need .conf: /etc/modprobe.d/unsupported-modules, it will be ignored in a future release.
WARNING: /etc/modprobe.d/unsupported-modules line 1: ignoring bad line starting with 'allow_unsupported_modules=1'
FATAL: Error inserting nvidia (/lib/modules/2.6.32-358.el6.x86_64/kernel/drivers/video/nvidia.ko): No such device
Platforms (1):
    [0] Intel(R) OpenCL [Selected]
Devices (4):
    [0]       Intel(R) Xeon(R) CPU E5-2697 v2 @ 2.70GHz [Selected]
    [1] Intel(R) Many Integrated Core Acceleration Card
    [2] Intel(R) Many Integrated Core Acceleration Card
    [3] Intel(R) Many Integrated Core Acceleration Card
Build program options: "-D__DO_FLOAT__ -cl-denorms-are-zero -cl-fast-relaxed-math -cl-single-precision-constant -DNSAMP=262144"
Running Monte Carlo options pricing for 65536 options, with 262144 samples
Size of memory region for each array: 262144 bytes
Using risk free rate = 0.05 and volatility = 0.2
Host time: 5.54317 sec.
Host perf: 11822.8 Options per second

 

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Looks like you have outdated MPSS version installed.

Please look here: https://software.intel.com/en-us/articles/installation-instructions/

 

I installed the latest MPSS, but it stll got the same error.

./montecarlo: relocation error: /opt/intel/opencl-1.2-4.4.0.117/lib64/libmic_device.so: symbol COIProcessSetCacheSize, version COI_1.0 not defined in file libcoi_host.so.0 with link time reference

 

 

Quote:

Dmitry Kaptsenel (Intel) wrote:

 

Looks like you have outdated MPSS version installed.

 

Please look here: https://software.intel.com/en-us/articles/installation-instructions/

 

 

 

 

Please try to uninstall previous MPSS version and then install MPSS 3.2.3 from this page https://software.intel.com/en-us/articles/intel-manycore-platform-software-stack-mpss

 

Thanks!

I use the command /opt/intel/mic/bin/micinfo  but found that it was MPSS Version : 2.1.6720-19

and I reinstall it thoroughly and now it can run opencl now.

 

 

 

Quote:

Dmitry Kaptsenel (Intel) wrote:

 

Please try to uninstall previous MPSS version and then install MPSS 3.2.3 from this page https://software.intel.com/en-us/articles/intel-manycore-platform-software-stack-mpss

 

 

 

Leave a Comment

Please sign in to add a comment. Not a member? Join today