Unable to create GPU accelerators

Unable to create GPU accelerators

Hello

I am using the February Preview of IPP Asynchronous Libraries for C/C++. I have been working on a project which requires me to create a single accelerator from a file and use it over multiple files. CPU accelerator created in this manner is being used over the files without any problem and generating the expected results. However, when I direct the program to create a GPU accelerator, it still creates a CPU accelerator. 

The examples provided with the Feb release are successfully creating a GPU accelerator (HPP_ACCEL_TYPE_GPU_VIA_DX9) when directed, hence the system specifications and drivers are in place.

Is it because I am writing the code on one machine and using the generated dlls for running a program on another machine?

Both the machines have the IPP February release installed, but only one(destination machine) has the hardware specifications capable of GPU acceleration. I am writing the code on another(source) machine, building it, and transferring the dlls generated to the destination machine. 

Thanks.

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hello

Update: The problem seems to be that operating through .dll, the machine cannot generate GPU accelerators and hence proceeds with CPU acceleration. Hence, is their a way to produce GPU acceleration through .dll as happens with .exe? 

Hello

Update: GPU acceleration through .dlls can be obtained by copying the runtime dlls from the IPP-A installation directory to the directory containing the generated dlls. 

Thanks to Dmitry from Intel for suggesting this.

Thanks.

Leave a Comment

Please sign in to add a comment. Not a member? Join today