Running OpenCL on Xeon® Processor E5-2609

Running OpenCL on Xeon® Processor E5-2609

I'd like to try some OpenCL/Ivy Bridge experiments on the Intel® Xeon® Processor E5-2609 v2. It seems clear that it should have the on-chip GPU. Servers with an on-chip GPU are very interesting.

We have a Dell t5610 with that chip in it, but, when I run my little test, which works just fine on my laptop with this chip: Intel(R) Core(TM) i3-3120M

OpenCL could only see the NVIDIA/CUDA platform, I tried installing the Intel graphics driver for HD graphics (Driver Version: 15.33.22.64.3621), but that did not work. No matching devices. I can send the install log, but, it seems pretty boring. The t5610 does not have a VGA connector, so, I cannot pull out the NVIDIA.

Does anyone have any suggestions?

 

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

OK, so, I'm an idiot. Now I have installed the OpenCL™ Runtime for Intel® CPU and Intel® Xeon Phi™ coprocessor

    Product:    OpenCL™ Runtime for Intel® CPU and Intel® Xeon Phi™ coprocessor
    Version:    4.4.0.117
    File version:    4.4.0.117
    Create time:    Thu May 08 12:34:16 2014

But, it still does not show any Intel Platforms.

OK, upgarade SDK & runtimes and now I get:

OpenGL version 4.3.0 - NVIDIA Corporation - Quadro K2000/PCIe/SSE2
Platform idx 0 id = 04F26C20 name = NVIDIA CUDA V.1.1 nGPUdevices 1 CPU 0 All 1
Platform idx 1 id = 03695BE8 name = Intel(R) OpenCL V.1.2 nGPUdevices 0 CPU 1 All 1

The processor string is: Intel(R) Xeon(R) CPU E5-2609 v2 @ 2.50GHz

Intel(R) Core(TM) i3-3120M

 

I get:

OpenGL version 4.0.0 - Build 10.18.10.3621 - Intel - Intel(R) HD Graphics 4000
Platform idx 0 id = 027EA068 name = Intel(R) OpenCL V.1.2 nGPUdevices 1 CPU 1 All 2

Device id = 03E1401C name = Intel(R) HD Graphics 4000 - Intel(R) Corporation OpenCL 1.2  10.18.10.3621

 

Leave a Comment

Please sign in to add a comment. Not a member? Join today